Cows POJ - 3348 凸包面积

Your friend to the south is interested in building fences and turning plowshares into swords. In order to help with his overseas adventure, they are forced to save money on buying fence posts by using trees as fence posts wherever possible. Given the locations of some trees, you are to help farmers try to create the largest pasture that is possible. Not all the trees will need to be used.

However, because you will oversee the construction of the pasture yourself, all the farmers want to know is how many cows they can put in the pasture. It is well known that a cow needs at least 50 square metres of pasture to survive.

Input

The first line of input contains a single integer, n (1 ≤ n ≤ 10000), containing the number of trees that grow on the available land. The next n lines contain the integer coordinates of each tree given as two integers x and y separated by one space (where -1000 ≤ x, y ≤ 1000). The integer coordinates correlate exactly to distance in metres (e.g., the distance between coordinate (10; 11) and (11; 11) is one metre).

Output

You are to output a single integer value, the number of cows that can survive on the largest field you can construct using the available trees.

Sample Input
4
0 0
0 101
75 0
75 101
Sample Output
151

思路:求凸包的面积,起始点与每一个点链接,把凸包分解为很多三角形,然后叉乘求面积,可以说是纯模板了;

#include<stdio.h>
#include<math.h>
#include<algorithm>
#include<iostream>
using namespace std;
const int MAXN=1000+10;
int n;
struct point
{
    int x,y;
};
point p[MAXN];
int stk[MAXN],top;
int cross(point p0,point p1,point p2) //计算叉积  p0p1 X p0p2
{
    return (p1.x-p0.x)*(p2.y-p0.y)-(p1.y-p0.y)*(p2.x-p0.x);
}
double dis(point p1,point p2)  //计算 p1p2的 距离
{
    return sqrt((double)(p2.x-p1.x)*(p2.x-p1.x)+(p2.y-p1.y)*(p2.y-p1.y));
}
bool cmp(point p1,point p2) //极角排序函数 , 角度相同则距离小的在前面
{
    int tmp=cross(p[0],p1,p2);
    if(tmp>0) return true;
    else if(tmp==0&&dis(p[0],p1)<dis(p[0],p2)) return true;
    else return false;
}
int graham()
{
    int i;
    if(n==1)
    {
        top=0;
        stk[0]=0;
    }
    if(n==2)
    {
        top=1;
        stk[0]=0;
        stk[1]=1;
    }
    if(n>2)
    {
        for(i=0; i<=1; i++) stk[i]=i;
        top=1;
        for(i=2; i<n; i++)
        {
            while(top>0&&cross(p[stk[top-1]],p[stk[top]],p[i])<=0) top--;
            stk[++top]=i;
        }
    }
    int sum=0;
    for(int i=1; i<top; i++)//面积累加
    {
        sum+=cross(p[0],p[stk[i]],p[stk[i+1]]);
    }
    return sum/100;
}
int main()
{


    int i,k;
    point p0;
    scanf("%d",&n);
    scanf("%d%d",&p[0].x,&p[0].y);
    p0.x=p[0].x;
    p0.y=p[0].y;
    k=0;
    for(i=1; i<n; i++)
    {
        scanf("%d%d",&p[i].x,&p[i].y);
        if( (p0.y>p[i].y) || ((p0.y==p[i].y)&&(p0.x>p[i].x)) )
        {
            p0.x=p[i].x;
            p0.y=p[i].y;
            k=i;
        }
    }
    p[k]=p[0];
    p[0]=p0;
    sort(p+1,p+n,cmp);
    int ans=graham();//凸包
    printf("%d\n",ans);

}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值