POJ 3694 Network tarjan+LCA

A network administrator manages a large network. The network consists of N computers and M links between pairs of computers. Any pair of computers are connected directly or indirectly by successive links, so data can be transformed between any two computers. The administrator finds that some links are vital to the network, because failure of any one of them can cause that data can't be transformed between some computers. He call such a link a bridge. He is planning to add some new links one by one to eliminate all bridges.

You are to help the administrator by reporting the number of bridges in the network after each new link is added.

Input

The input consists of multiple test cases. Each test case starts with a line containing two integers N(1 ≤ N ≤ 100,000) and M(N - 1 ≤ M ≤ 200,000).
Each of the following M lines contains two integers A and B ( 1≤ AB ≤ N), which indicates a link between computer A and B. Computers are numbered from 1 to N. It is guaranteed that any two computers are connected in the initial network.
The next line contains a single integer Q ( 1 ≤ Q ≤ 1,000), which is the number of new links the administrator plans to add to the network one by one.
The i-th line of the following Q lines contains two integer A and B (1 ≤ ABN), which is the i-th added new link connecting computer A and B.

The last test case is followed by a line containing two zeros.

Output

For each test case, print a line containing the test case number( beginning with 1) and Q lines, the i-th of which contains a integer indicating the number of bridges in the network after the first i new links are added. Print a blank line after the output for each test case.

Sample Input
3 2
1 2
2 3
2
1 2
1 3
4 4
1 2
2 1
2 3
1 4
2
1 2
3 4
0 0
Sample Output
Case 1:
1
0

Case 2:
2
0

问:在给定的两个节点添加一条边之后还有多少桥。

思路:添加一条边(a,b),实际是把 从LCA(a,b)出发到a,b的路径上的桥全部删除掉。这样的话我们只需要在求lca的过程中把路径中的桥全部删除。

#include <stdio.h>
#include <string.h>
const int MAXN=100005;
struct node
{
    int to,next;
} edge[MAXN*4];
int head[MAXN],dfn[MAXN],low[MAXN],pre[MAXN],vis[MAXN],n,m,time,cnt,cut;
bool bi[MAXN];
void init()
{
    memset(vis,0,sizeof(vis));
    memset(head,-1,sizeof(head));
    memset(dfn,0,sizeof(dfn));
    memset(low,0,sizeof(low));
    for(int i=0; i<=n; pre[i]=i,i++);
    memset(bi,0,sizeof(bi));
    cnt=0;
    cut=0;
    time=1;
}
int min(int a,int b)
{
    if(a>b)a=b;
    return a;
}
void addedge(int u,int v)
{
    edge[cnt].to=v;
    edge[cnt].next=head[u];
    head[u]=cnt;
    cnt++;
}
void dfs(int u,int fa)
{
    dfn[u]=time;
    low[u]=time;
    time++;
    vis[u]=1;
    for(int i=head[u]; i!=-1; i=edge[i].next)
    {
        int v=edge[i].to;
        if(!vis[v])
        {
            dfs(v,u);
            pre[v]=u;
            low[u]=min(low[u],low[v]);
            if(low[v] > dfn[u])
            {
                cut++;
                bi[v] = true;
            }
        }
        else if(vis[v] == 1 && v != fa)
        {
            low[u]=min(low[u],dfn[v]);
        }
    }
    vis[u]=-1;
}
int LCA(int u,int v)
{
    int cnt1=0;
    while(dfn[u]>dfn[v])
    {
        if(bi[u])
        {
            cnt1++;
            bi[u]=false;
        }
        u=pre[u];
    }
    while(dfn[u]<dfn[v])
    {
        if(bi[v])
        {
            cnt1++;
            bi[v]=false;
        }
        v=pre[v];
    }
    while(u!=v)
    {
        if(bi[u])
        {
            bi[u]=false;
            cnt1++;
        }
        if(bi[v])
        {
            bi[v]=false;
            cnt1++;
        }
        u=pre[u];
        v=pre[v];
    }
    return cnt1;
}
int main()
{
    int u,v,q,in=0;
    while(scanf("%d%d",&n,&m),n+m)
    {
        if(in)
        {
            puts("");
        }
        in++;
        init();
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&u,&v);
            u--;
            v--;
            addedge(u,v);
            addedge(v,u);
        }
        dfs(0,0);
        scanf("%d",&q);
        printf("Case %d:\n",in);
        for(int i=0; i<q; i++)
        {
            scanf("%d%d",&u,&v);
            u--;
            v--;
            cut-=LCA(u,v);
            printf("%d\n",cut);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值