Multiplication Puzzle POJ - 1651 区间dp

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row.

The goal is to take cards in such order as to minimize the total number of scored points.

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.
Input
The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.
Output
Output must contain a single integer - the minimal score.
Sample Input
6
10 1 50 50 20 5
Sample Output
3650


这道题dp出口把我卡死了,每做一道dp准有一东西把我卡死。但是好像我会写dp循环顺序了?

这道题只要能想通左右边界的点根本是不可能消失的就行了。也就是说不会取左右边界

既然不会取左右边界的话我们就枚举(区间dp老套路)最后一个点就行了,枚举了之后就把区间分割为两部分,dp[l][k],dp[k][r],因为中间的k对于左右两区间来说都是不可取的,这样的话我们直接取这个值就好了,最后加起来求一个最小值

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int dp[110][110],s[110];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        memset(dp,0x3f3f3f3f,sizeof(dp));
        for(int i=1; i<=n; i++)
            scanf("%d",&s[i]);
        for(int i=2; i<=n; i++)
            dp[i-1][i]=0;
        for(int i=2; i<=n; i++)
        {
            for(int j=1,k=i; k<=n; k++,j++)
            {
                for(int t=j+1; t<k; t++)
                {
                    dp[j][k]=min(dp[j][k],s[j]*s[k]*s[t]+dp[j][t]+dp[t][k]);
                }
            }
        }
        printf("%d\n",dp[1][n]);
    }
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值