J - Wooden Sticks poj 1065

Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows: 
(a) The setup time for the first wooden stick is 1 minute. 
 (b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l <= l' and w <= w'. Otherwise, it will need 1 minute for setup. 
You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are ( 9 , 4 ) , ( 2 , 5 ) , ( 1 , 2 ) , ( 5 , 3 ) , and ( 4 , 1 ) , then the minimum setup time should be 2 minutes since there is a sequence of pairs ( 4 , 1 ) , ( 5 , 3 ) , ( 9 , 4 ) , ( 1 , 2 ) , ( 2 , 5 ) .

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1 <= n <= 5000 , that represents the number of wooden sticks in the test case, and the second line contains 2n positive integers l1 , w1 , l2 , w2 ,..., ln , wn , each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1 

Sample Output

2
1
3

题意大致是:有一些木棒需要加工,每个木棒加工的时间花费是1,如果后面的木棒的质量和长度都大于前面的木棒,则不需要花费时间。求加工完所有木棒所需的最小时间。

输入:第一行的数字表示样例的个数,每两行一个样例;每个样例第一行表示木棒的个数,接下来每两个数字表示一个木棒,第一个数字表示长度第二个数字表示质量。


本题其实是在求升列的最小个数

首先将所有的木棒按照长度从小到大排列,如果长度相等则按照质量从小到大排列。

然后从a[st+1]开始向后扫描,记录不符合条件的第一个木棒,标记为st,下一次扫描从该木棒开始。

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<string>
#include<string.h>
using namespace std;
struct stick
{
    int len;
    int wei;
}a[5001];
bool used[5001];
bool cmp(stick k1,stick k2)
{
    if(k1.len==k2.len)
        return k1.wei<k2.wei;
    else
        return k1.len<k2.len;
}
int main()
{
    int T,n,i,j,st,count;
    bool flag;
    cin>>T;
    while(T--)
    {
        cin>>n;
        for(i=0;i<n;i++)
            cin>>a[i].len>>a[i].wei;
        sort(a,a+n,cmp);
        memset(used,false,sizeof(used));
        used[0]=true;
        st=0;
        count=0;
        while(st<n)
        {
            count++;
            for(i=st+1,j=st,flag=true;i<n;i++)
            {
                if(used[i])
                    continue;
                if(a[j].len<=a[i].len&&a[j].wei<=a[i].wei)
                {
                    used[i]=true;
                    j=i;
                }
                else
                {
                    if(flag)//标记新的第一个木棒
                    {
                        st=i;
                        flag=false;
                    }
                }
            }
            if(flag)
                break;
        }
        cout<<count<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值