POJ 2104 K-th Number


You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment. 
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?" 
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.
Input
The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000). 
The second line contains n different integer numbers not exceeding 10  9 by their absolute values --- the array for which the answers should be given. 
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).
Output
For each question output the answer to it --- the k-th number in sorted a[i...j] segment.
Sample Input
7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3
Sample Output
5
6
3
Hint
This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.
可持久化线段树(主席树)链接


#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;
#define maxn 100000
int a[maxn+10],aa[maxn+10];
struct rec
{
    int l,r,ls,rs,w;//当前结点的区域l-r,ls、rs左右儿子的节点,当前区域内有多少个数(算重复的,1、1算两个数)
    void init(int s,int t)
    {
        l=s,r=t;
        ls=rs=0;
    }
}seg[maxn*20];
int root[maxn*20];//保存各根节点
int cnt=0;//记录节点数
void build(int &x,int l,int r)
{
    if(x==0)
    {
        x=++cnt;
        seg[x].init(l,r);
        seg[x].w=0;
    }
    if(l==r)
        return ;
    int mid=l+r>>1;
    build(seg[x].ls,l,mid);
    build(seg[x].rs,mid+1,r);
}
void update(int &x,int rot,int l,int r,int k)//“&”更新或赋值给x对应的节点
{
    if(x==0)
    {
        x=++cnt;seg[x].init(l,r);seg[x].w=seg[rot].w+1;//在查找k的时候,经过的肯定都是k的祖先,直接把祖先都加1
    }
    if(l==r)
        return ;
    int mid=(l+r)>>1;
    if(k<=mid)
    {
        seg[x].rs=seg[rot].rs;
        update(seg[x].ls,seg[rot].ls,l,mid,k);
    }
    else
    {
        seg[x].ls=seg[rot].ls;
        update(seg[x].rs,seg[rot].rs,mid+1,r,k);
    }
}
int cal(int x,int y,int l,int r,int k)
{
    if(l==r)
        return l;
    int mid=(l+r)>>1;
    if(k<=seg[seg[y].ls].w-seg[seg[x].ls].w)
        return cal(seg[x].ls,seg[y].ls,l,mid,k);
    else
    {
        k-=seg[seg[y].ls].w-seg[seg[x].ls].w;
        return cal(seg[x].rs,seg[y].rs,mid+1,r,k);
    }
}
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        for(int i=0;i<n;i++)
            aa[i]=a[i];
        sort(a,a+n);
        int cnts=unique(a,a+n)-a;
        build(root[0],1,cnts);
        for(int i=0;i<n;i++)
        {
            root[i+1]=0;
            int res=lower_bound(a,a+cnts,aa[i])-a;
            update(root[i+1],root[i],1,cnts,res+1);//线段树保存的是1-m,res的范围是0-(m-1)
        }
        for(int i=0;i<m;i++)
        {
            int q,r,t;
            scanf("%d%d%d",&q,&r,&t);
            printf("%d\n",a[cal(root[q-1],root[r],1,cnts,t)-1]);//记得将序号转化成原来的数值
        }
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值