HDU 4282 A very hard mathematic problem(暴力优化)

原题:http://acm.hdu.edu.cn/showproblem.php?pid=4282

A very hard mathematic problem

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3871    Accepted Submission(s): 1133


Problem Description
  Haoren is very good at solving mathematic problems. Today he is working a problem like this: 
  Find three positive integers X, Y and Z (X < Y, Z > 1) that holds
   X^Z + Y^Z + XYZ = K
  where K is another given integer.
  Here the operator “^” means power, e.g., 2^3 = 2 * 2 * 2.
  Finding a solution is quite easy to Haoren. Now he wants to challenge more: What’s the total number of different solutions?
  Surprisingly, he is unable to solve this one. It seems that it’s really a very hard mathematic problem.
  Now, it’s your turn.
 

Input
  There are multiple test cases. 
  For each case, there is only one integer K (0 < K < 2^31) in a line.
  K = 0 implies the end of input.
  
 

Output
  Output the total number of solutions in a line for each test case.
 

Sample Input
  
  
9 53 6 0
 

Sample Output
  
  
1 1 0
题意:求出符合上面式子的个数

AC代码:

#include <stdio.h>
#include <math.h>
#define LL __int64
/*
author:YangSir
time:2014/5/9
*/
LL qpow(LL x,LL y) 
{ 
    LL temp=x,i; 
    for(i=2;i<=y;i++) 
		temp*=x; 
    return temp; 
} 

int main()
{
	LL n,m,x,y,z,k,s,num;
	while(~scanf("%I64d",&k)&&k)
	{
		num=0;
		s=sqrt(k);
		if(s*s==k)
		{
			num+=(s-1)/2;//当z为2时,式子符合完全平方,只要求组成s的x、y的个数(x<y)
		}
		for(z=3;z<31;z++)
		{
			for(x=1;;x++)
			{
				if(qpow(x,z)>=k/2)//因为想x<y,所以当这大于k/2是一定不存在
					break;
				for(y=x+1;;y++)
				{
					if(qpow(x,z)+qpow(y,z)+x*y*z>k)//大于显然不符合
						break;
					if(qpow(x,z)+qpow(y,z)+x*y*z==k)
					{
						num++;
						break;//只有一次
					}
				}
			}
		}
		printf("%I64d\n",num);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值