ZOJ 3167(大数乘小数的简单应用)

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemId=3199

Find 7 Faster Than John Von Neumann

Time Limit: 1 Second Memory Limit: 32768 KB

It was said that when testing the first computer designed by von Neumann, people gave the following problem to both the legendary professor and the new computer: If the 4th digit of 2^n is 7, what is the smallest n? The machine and von Neumann began computing at the same moment, and von Neumann gave the answer first.

Now you are challenged with a similar but more complicated problem: If the K-th digit of M^n is 7, what is the smallest n?

Input

Each case is given in a line with 2 numbers: K and M (< 1,000).

Output

For each test case, please output in a line the smallest n.

You can assume:

  1. The answer always exist.
  2. The answer is no more than 100.

Sample Input

3 2
4 2
4 3

Sample Output

15
21
11
AC代码:

#include <stdio.h>
#include <string.h>
int a[300],b[300];
void mul(int i){
    int j,k;
    for(j=0;j<300;j++)
        b[j]*=i;
    for(i=k=0;i<300;i++){
        j=(b[i]+k)/10;
        b[i]=(b[i]+k)%10;
        k=j;
    }
}
int main(){
    int n,k,m,i,p;
    while(~scanf("%d%d",&k,&m)){
        memset(a,0,sizeof(a));
        memset(b,0,sizeof(b));
        p=m;
        n=1;
        for(i=0;p;i++){
            a[i]=b[i]=p%10;
            p/=10;
        }
        while(a[k-1]-7){
			mul(m);
            for(i=0;i<300;i++)
                a[i]=b[i];
            n++;
        }
        printf("%d\n",n);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值