Catch That Cow【广搜】

Catch That Cow

 POJ - 3278 

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points - 1 or + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

 

依旧是广搜的模板题

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
#define ms(arr) memset(arr,0,sizeof(arr))
/*priority_queue<int,vector<int> ,greater<int> >q;*/
const int maxn = (int)1e5 + 5;
const ll mod = 1e9+7;
bool vis[maxn];
int step[maxn];
int bfs(int s,int e)
{
    queue<int> q;
    q.push(s);
    step[s]=0;
    vis[s]=true;
    while(!q.empty())
    {
        int front=q.front();
        q.pop();
        if(front+1>0&&front+1<=1e5&&vis[front+1]==false)
        {
            q.push(front+1);
            vis[front+1]=true;
            step[front+1]=step[front]+1;
            if(front+1==e)
                return step[front+1];
        }
        if(front-1>0&&front-1<=1e5&&vis[front-1]==false)
        {
            q.push(front-1);
            vis[front-1]=true;
            step[front-1]=step[front]+1;
            if(front-1==e)
                return step[front-1];
        }
        if(front*2>0&&front*2<=1e5&&vis[front*2]==false)
        {
            q.push(front*2);
            vis[front*2]=true;
            step[front*2]=step[front]+1;
            if(front*2==e)
                return step[front*2];
        }
    }
}
int main() 
{
    //freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
    ios::sync_with_stdio(0),cin.tie(0);
    int N,K;
    cin>>N>>K;
    ms(vis);ms(step);
    if(N>=K)
        cout<<N-K<<endl;
    else
        cout<<bfs(N,K)<<endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值