建有序链表,还是要打好基础的。。。

Description

输入N个无序的整数,建立一个有序链表,链表中的结点按照数值非降序排列,输出该有序链表。

Input

第一行输入整数个数N; 
第二行输入N个无序的整数。

Output

依次输出有序链表的结点值。

Sample Input

6
33 6 22 9 44 5

Sample Output

5 6 9 22 33 44

Hint

不得使用数组!

#include<stdio.h>
#include<stdlib.h>
#define SK struct K *
struct K
{
    int date;
    struct K *next;
}*head;
int main()
{
    int n,t;
    struct K *p,*r,*q,*pa;
    head=(SK)malloc(sizeof(struct K));
    head->next=NULL;
    p=(SK)malloc(sizeof(struct K));
    r=(SK)malloc(sizeof(struct K));
    q=(SK)malloc(sizeof(struct K));
    pa=(SK)malloc(sizeof(struct K));
    scanf("%d",&n);
    while(n--)
    {
        r=(SK)malloc(sizeof(struct K));
        scanf("%d",&r->date);
        pa=head;
        q=head->next;
       while(q!=NULL)
        {

            if(r->date<q->date)
            {
                r->next=pa->next;
                pa->next=r;
                break;
            }
            pa=q;
            q=q->next;
        }
        if(q==NULL)
        {
          r->next=pa->next;
            pa->next=r;
        }
    }
    p=head->next;
    while(p!=NULL)
    {

        printf("%d",p->date);
        p=p->next;
        if(p!=NULL)
            printf(" ");
    }
    printf("\n");
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值