统计字符串-Java

统计一个字符串中数字、大写字母、小写字母各自出现的次数。(提示:查询API文档中的Character类)。

输入

输入一个字符串

输出

输出数字、大写字母、小写字母各自出现的次数。
输出格式:System.out.println("数字:"+times_number);
System.out.println("小写字母:"+times_lower);
System.out.println("大写字母:"+times_upper);

难度

一般

输入示例

123abc+()Abc!@#cde<>CDEA

输出示例

数字:3
小写字母:8
大写字母:5
import java.util.Scanner;
 
public class zifuchuan2 {
 
    public static void main(String[] args) {
        // TODO Auto-generated method stub
       Scanner sd=new Scanner(System.in);
       String s;
       s=sd.nextLine();
       int times_number=0;
       int times_lower=0;
       int times_upper=0;
      for(int i=0;i<s.length();i++){
          char c=s.charAt(i);//将字符串拆分为单个字段
          if(Character.isUpperCase(c)) {
                  times_upper++;}
          if(Character.isLowerCase(c)) {
                   times_lower++;}
          if(Character.isDigit(c)) {
                times_number++;
              }
               
          }
      System.out.println("数字:"+times_number);
      System.out.println("小写字母:"+times_lower);
      System.out.println("大写字母:"+times_upper);
      }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

小杨不想秃头

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值