1028. List Sorting (25)

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
Sample Output 3
000001 Zoe 60
000007 James 85
000002 James 90

000010 Amy 90

最后一个点运行超时
import java.util.Arrays;
import java.util.Comparator;
import java.util.Scanner;

class Student{
	int sid;
	String sname;
	int score;
}
class SortByNumber_1 implements Comparator<Student>{
	//1,学号升序
	public int compare(Student o1, Student o2) {
		return o1.sid - o2.sid;
	}	
}
class SortByNumber_2 implements Comparator<Student>{
	//2,名字字母升序
	public int compare(Student o1, Student o2) {
		//如果字母相同,按学号升序
		if((o1.sname.charAt(0) - 48) == (o2.sname.charAt(0) - 48)){
			return o1.sid - o2.sid;
		}
		return (o1.sname.charAt(0) - 48) - (o2.sname.charAt(0) - 48);
	}
}
class SortByNumber_3 implements Comparator<Student>{
	//3,成绩升序
	public int compare(Student o1, Student o2) {
		//如果成绩相同,按学号升序
		if(o1.score == o2.score){
			return o1.sid - o2.sid;
		}
		return o1.score - o2.score;
	}
	
}
public class Main{

	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		int sum = in.nextInt(),charge = in.nextInt();
		Student[] stu = new Student[sum];
		for ( int i = 0; i < sum; i++ ){
			stu[i] = new Student();
			stu[i].sid = in.nextInt();
			stu[i].sname = in.next();
			stu[i].score = in.nextInt();
		}
		switch (charge) {
		case 1:
			SortByNumber_1 sb_1 = new SortByNumber_1();
			Arrays.sort(stu,sb_1);
			break;
		case 2:
			SortByNumber_2 sb_2 = new SortByNumber_2();
			Arrays.sort(stu,sb_2);
			break;
		case 3:
			SortByNumber_3 sb_3 = new SortByNumber_3();
			Arrays.sort(stu,sb_3);
			break;
		}
		for ( int i = 0; i < sum; i++ ){
			System.out.printf("%06d",stu[i].sid);
			System.out.println(" "+stu[i].sname+" "+stu[i].score);
		}
	}

}
升序:o1.sid-o2.sid
降序:o2.sid-o1.sid
注意:
for ( int i = 0; i < sum; i++ ){
			stu[i] = new Student();
			stu[i].sid = in.nextInt();
			stu[i].sname = in.next();
			stu[i].score = in.nextInt();
		}

stu[i] = new Student();
new数组的时候并没有实例化stu[i],如果不实例化stu[i],会空指针异常
参考:http://www.2cto.com/kf/201504/395324.html
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值