Description
读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。
Input
测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。
Output
对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。
Sample Input
1 + 2
4 + 2 * 5 - 7 / 11
0
Sample Output
3.00
13.36
这道题的题面提到"整数和运算符之间用一个空格分隔",所以写的时候不要想得太多,用字符串太复杂了,所以只要控制输入的格式就会简单很多,再配合栈,这道题就解决了
#include<bits/stdc++.h>
using namespace std;
typedef long long lint;
const int maxn=10005;
stack<double> s1;
stack<char> s2;
int main()
{
double a;
while(~scanf("%lf",&a)){//不可以在这里判断输入为0结束哦,因为算式可能是0+..等等
s1.push(a);
while(getchar()!='\n'){
double n;
char c;
scanf("%c %lf",&c,&n);
if(c=='+'){
s1.push(n);
}else if(c=='-'){
s1.push(-1*n);
}else if(c=='*'){
double b=s1.top();
s1.pop();
b=b*n;
s1.push(b);
}else if(c=='/'){
double b=s1.top();
s1.pop();
b=b*1.0/n;
s1.push(b);
}
}
if(s1.size()==1&&s1.top()==0)//题目提到输入0结束,所以判断数字入完栈之后栈的大小和栈顶元素是否为0就可以了
break;
double b=s1.top();
s1.pop();
while(!s1.empty()){
b=b+s1.top();
s1.pop();
}
printf("%.2f\n",b);
}
return 0;
}