HDU 1043 Eight (八数码问题 康托展开 bfs)

16 篇文章 0 订阅

题面

The 15-puzzle has been around for over 100 years; even if you don't know it by that name, you've seen it. It is constructed with 15 sliding tiles, each with a number from 1 to 15 on it, and all packed into a 4 by 4 frame with one tile missing. Let's call the missing tile 'x'; the object of the puzzle is to arrange the tiles so that they are ordered as:

 1  2  3  4
 5  6  7  8
 9 10 11 12
13 14 15  x


where the only legal operation is to exchange 'x' with one of the tiles with which it shares an edge. As an example, the following sequence of moves solves a slightly scrambled puzzle:

 1  2  3  4     1  2  3  4     1  2  3  4     1  2  3  4
 5  6  7  8     5  6  7  8     5  6  7  8     5  6  7  8
 9  x 10 12     9 10  x 12     9 10 11 12     9 10 11 12
13 14 11 15    13 14 11 15    13 14  x 15    13 14 15  x
            r->            d->            r->


The letters in the previous row indicate which neighbor of the 'x' tile is swapped with the 'x' tile at each step; legal values are 'r','l','u' and 'd', for right, left, up, and down, respectively.

Not all puzzles can be solved; in 1870, a man named Sam Loyd was famous for distributing an unsolvable version of the puzzle, and
frustrating many people. In fact, all you have to do to make a regular puzzle into an unsolvable one is to swap two tiles (not counting the missing 'x' tile, of course).

In this problem, you will write a program for solving the less well-known 8-puzzle, composed of tiles on a three by three
arrangement.

Input

You will receive, several descriptions of configuration of the 8 puzzle. One description is just a list of the tiles in their initial positions, with the rows listed from top to bottom, and the tiles listed from left to right within a row, where the tiles are represented by numbers 1 to 8, plus 'x'. For example, this puzzle

1 2 3
x 4 6
7 5 8

is described by this list:

1 2 3 x 4 6 7 5 8

Output

You will print to standard output either the word ``unsolvable'', if the puzzle has no solution, or a string consisting entirely of the letters 'r', 'l', 'u' and 'd' that describes a series of moves that produce a solution. The string should include no spaces and start at the beginning of the line. Do not print a blank line between cases.

Sample Input

2  3  4  1  5  x  7  6  8

Sample Output

ullddrurdllurdruldr

题目链接

Eight 


参考链接

题解:hdu1043Eight (经典的八数码)(康托展开+BFS)

康托展开:百度百科——康托展开


题目简述

树状bfs,因为测试样例过多,先打表,后直接输出结果


程序分析

factorial[10]:阶乘(9的阶乘)

dire_x[]、dire_y[]方向数组

w[]方向的(相反)字母

temp[]暂时存放数码

s[]字符串数组

Node树的节点(“987654321”的康托展开值为362879)

Path状态


程序

#include<stdio.h>
#include<iostream>
#include<queue>
using namespace std;

int factorial[10];
int dire_x[]={0,0,1,-1};
int dire_y[]={1,-1,0,0};
char w[]="lrud";
int temp[10];
char s[50];

struct Node
{
    char way;
    int father;
}node[370000];

struct Path
{
    int a[10];
    int where/**x在a中的位置**/,Can_num;
};
void set_factorial()/**计算阶乘**/
{
    factorial[0]=1;
    for(int i=1;i<=8;i++)
    {
        factorial[i]=factorial[i-1]*i;
    }
}

int cantor(int can[])/**康托展开**/
{
    int ans=0,k;
    for(int i=0;i<9;i++)
    {
        k=0;
        for(int j=i+1;j<9;j++)
            if(can[j]<can[i])
                k++;
        ans+=k*factorial[8-i];
    }
    return ans;
}

void copy_Path(Path &x,Path y)
{
    for(int i=0;i<9;i++)
        x.a[i]=y.a[i];
    x.where=y.where;
    x.Can_num=y.Can_num;
}


void bfs(int xx[])
{
    queue<Path>Q;
    Path p,q;
    for(int i=0;i<9;i++)
        q.a[i]=xx[i];
    q.where=8;q.Can_num=0;
    node[q.Can_num].father=0;
    Q.push(q);
    while(!Q.empty())
    {
        copy_Path(q,Q.front());
        Q.pop();

        for(int i=0;i<4;i++)
        {
            copy_Path(p,q);

            int x=q.where/3+dire_x[i];
            int y=q.where%3+dire_y[i];
            if(x>=0&&x<3&&y>=0&&y<3)
            {
                p.where=x*3+y;
                int temp=p.a[p.where];
                p.a[p.where]=p.a[q.where];
                p.a[q.where]=temp;
                p.Can_num=cantor(p.a);

                if(node[p.Can_num].father==-1)
                {
                    node[p.Can_num].father=q.Can_num;
                    node[p.Can_num].way=w[i];
                    Q.push(p);
                }
            }
        }
    }
}
int main()
{
    for(int i=0;i<9;i++)
        temp[i]=i+1;
    for(int i=0;i<370000;i++)
        node[i].father=-1;
    set_factorial();
    bfs(temp);
    while(gets(s))
    {
        int j=0;
        for(int i=0;s[i]!='\0';i++)
        {
            if(s[i]=='x')
                temp[j++]=9;
            else if(s[i]>='0'&&s[i]<='8')
                temp[j++]=s[i]-'0';
        }
        int cant=cantor(temp);
        if(node[cant].father==-1)
        {
            printf("unsolvable\n");
            continue;
        }
        while(cant!=0)
        {
            printf("%c",node[cant].way);
            cant=node[cant].father;
        }
        printf("\n");
    }
    return 0;
}
//参考题解https://blog.csdn.net/pi9nc/article/details/27580893

 

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值