HDU 6581 Vacation(思维)

2 篇文章 0 订阅

题面

Problem Description

Tom and Jerry are going on a vacation. They are now driving on a one-way road and several cars are in front of them. To be more specific, there are n cars in front of them. The i th car has a length of li , the head of it is si from the stop-line, and its maximum velocity is vi . The car Tom and Jerry are driving is l0 in length, and s0 from the stop-line, with a maximum velocity of v0 .
The traffic light has a very long cycle. You can assume that it is always green light. However, since the road is too narrow, no car can get ahead of other cars. Even if your speed can be greater than the car in front of you, you still can only drive at the same speed as the anterior car. But when not affected by the car ahead, the driver will drive at the maximum speed. You can assume that every driver here is very good at driving, so that the distance of adjacent cars can be kept to be 0 .
Though Tom and Jerry know that they can pass the stop-line during green light, they still want to know the minimum time they need to pass the stop-line. We say a car passes the stop-line once the head of the car passes it.
Please notice that even after a car passes the stop-line, it still runs on the road, and cannot be overtaken.

 

 

Input

This problem contains multiple test cases.
For each test case, the first line contains an integer n (1≤n≤105,∑n≤2×106 ), the number of cars.
The next three lines each contains n+1 integers, li,si,vi (1≤si,vi,li≤109 ). It's guaranteed that si≥si+1+li+1,∀i∈[0,n−1]

 

 

Output

For each test case, output one line containing the answer. Your answer will be accepted if its absolute or relative error does not exceed 10−6 .
Formally, let your answer be a , and the jury's answer is b . Your answer is considered correct if |a−b|max(1,|b|)≤10−6 .
The answer is guaranteed to exist.

 

 

Sample Input

 

1 2 2 7 1 2 1 2 1 2 2 10 7 1 6 2 1

 

 

Sample Output

 

3.5000000000 5.0000000000

 

题意

提供n+1辆车的车身长度、离终点线的距离和最大速度。每辆车不能超车。问:0号车通过终点线的时间?

题目链接

HDU 6581

参考

《第一场多校题解》

分析

提供n+1辆车的车身长度、离终点线的距离和最大速度。每辆车不能超车。问:0号车通过终点线的时间?

0号在理想情况下的最少时间(最快速度通过终点线),即没有与其他车相撞。即0号车的s/v

考虑撞车的结果,不考虑撞车的过程。

0号车通过终点线时,一定是被编号1-n中的编号为x的车堵着,0号车以x号车的速度通过终点线。则根据x号车到终点线的距离s,1-x号车总的车身长度得到距离 s+\sum_{i=1}^{x}l_{i},除以速度v_{x}。得到0号车被x号车堵着通过终点线的时间。

依次试探x=1,2,3,,,,,,,n

取所有时间里最慢的,即最大值。

因为假如可以以更少的时间通过终点线,则0号车可以穿过1-x号车中的一些车,所以不可行。

程序分析

car_length:1-x号车的总的车身长度。

程序

#include<stdio.h>
#include<iostream>
using namespace std;
#define maxn 100005
struct Car
{
    double s,l,v;
}car[maxn];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<=n;i++)
            scanf("%lf",&car[i].l);
        for(int i=0;i<=n;i++)
            scanf("%lf",&car[i].s);
        for(int i=0;i<=n;i++)
            scanf("%lf",&car[i].v);
        double answer=car[0].s/car[0].v;
        double car_length=0;
        for(int i=1;i<=n;i++)
        {
            car_length+=car[i].l;
            answer=max(answer,(car_length+car[i].s)/car[i].v);
        }
        printf("%.10lf\n",answer);
    }
    return 0;
}

2019年07月23日 09:32:23

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值