HDU 1067 Gap(bfs+哈希)

16 篇文章 0 订阅

题面

Let's play a card game called Gap.
You have 28 cards labeled with two-digit numbers. The first digit (from 1 to 4) represents the suit of the card, and the second digit (from 1 to 7) represents the value of the card.

First, you shu2e the cards and lay them face up on the table in four rows of seven cards, leaving a space of one card at the extreme left of each row. The following shows an example of initial layout.



Next, you remove all cards of value 1, and put them in the open space at the left end of the rows: "11" to the top row, "21" to the next, and so on.

Now you have 28 cards and four spaces, called gaps, in four rows and eight columns. You start moving cards from this layout.



At each move, you choose one of the four gaps and fill it with the successor of the left neighbor of the gap. The successor of a card is the next card in the same suit, when it exists. For instance the successor of "42" is "43", and "27" has no successor.

In the above layout, you can move "43" to the gap at the right of "42", or "36" to the gap at the right of "35". If you move "43", a new gap is generated to the right of "16". You cannot move any card to the right of a card of value 7, nor to the right of a gap.

The goal of the game is, by choosing clever moves, to make four ascending sequences of the same suit, as follows.



Your task is to find the minimum number of moves to reach the goal layout.

Input

The input starts with a line containing the number of initial layouts that follow.

Each layout consists of five lines - a blank line and four lines which represent initial layouts of four rows. Each row has seven two-digit numbers which correspond to the cards.

Output

For each initial layout, produce a line with the minimum number of moves to reach the goal layout. Note that this number should not include the initial four moves of the cards of value 1. If there is no move sequence from the initial layout to the goal layout, produce "-1".

Sample Input

4

12 13 14 15 16 17 21
22 23 24 25 26 27 31
32 33 34 35 36 37 41
42 43 44 45 46 47 11

26 31 13 44 21 24 42
17 45 23 25 41 36 11
46 34 14 12 37 32 47
16 43 27 35 22 33 15

17 12 16 13 15 14 11
27 22 26 23 25 24 21
37 32 36 33 35 34 31
47 42 46 43 45 44 41

27 14 22 35 32 46 33
13 17 36 24 44 21 15
43 16 45 47 23 11 26
25 37 41 34 42 12 31

Sample Output

0
33
60
-1

题目链接

HDU_1067

参考链接

hdu1067-Gap(bfs+哈希) Author:wust_ouyangli

分析

问多少步能到达目标状态?

如23后的空位填24,则17之后的空位填不了。

用hash判重

程序分析

void init_Base()初始化base数组

long long GetHash(int card[4][8])得到hash值

bool InsertHash(long long val)判重插入

bool Move(Table &t,int which)走一步

void init_start()初始化start

程序

#include<stdio.h>
#include<string.h>
#include<queue>
using namespace std;
int right[][8]= {{11,12,13,14,15,16,17,0},
    {21,22,23,24,25,26,27,0},
    {31,32,33,34,35,36,37,0},
    {41,42,43,44,45,46,47,0}
};
struct Node
{
    int x,y;
    Node(){}
    Node(int X,int Y):x(X),y(Y){}
    void change(int X,int Y){x=X,y=Y;}
};

struct Table
{
    int card[4][8];
    Node e_s[4];/**empty_space**/
    int step;
}start;
#define mod 1000007
long long hash_visit[mod];
long long base[35];
void init_Base()
{
    base[0]=1;
    for(int i=1;i<32;i++) base[i]=base[i-1]*2;
}
long long GetHash(int card[4][8])
{
    long long ret=0;
    for(int i=0; i<4; i++)
        for(int j=0; j<8; j++) ret+=(long long)card[i][j]*base[i*8+j];
    return ret;
}

bool InsertHash(long long val)
{
    long long v=val%mod;
    while(hash_visit[v]!=-1&&hash_visit[v]!=val)  v=(v+10)%mod;
    if(hash_visit[v]==-1)
    {
        hash_visit[v]=val;
        return true;
    }
    return false;
}

bool Move(Table &t,int which)
{
    Node Empty=t.e_s[which];
    int before_num=t.card[Empty.x][Empty.y-1];
    if(before_num==0||before_num%10==7)
        return false;
    int new_num=before_num+1;
    Node where;
    for(int i=0;i<4;i++)
        for(int j=1;j<8;j++)
            if(t.card[i][j]==new_num)
            {
                t.card[i][j]=0;
                t.e_s[which].change(i,j);
                break;
            }
    t.card[Empty.x][Empty.y]=new_num;
    t.step++;
    return true;
}

void init_start()
{
    memset(hash_visit,-1,sizeof(hash_visit));
    start.card[0][0]=11;
    start.card[1][0]=21;
    start.card[2][0]=31;
    start.card[3][0]=41;
    for(int i=0;i<4;i++)
        for(int j=1;j<=7;j++)
        {
            scanf("%d",&start.card[i][j]);
            int temp=start.card[i][j];
            if(temp%10==1)
            {
                start.card[i][j]=0;
                start.e_s[temp/10-1].change(i,j);
            }
        }
    start.step=0;
}

int bfs()
{
    long long goal_hash=GetHash(right);
    queue<Table>q;
    q.push(start);
    long long start_hash=GetHash(start.card);
    if(start_hash==goal_hash)
        return start.step;

    InsertHash(start_hash);
    while(!q.empty())
    {
        Table now,next;
        now=q.front();
        q.pop();
        for(int i=0;i<4;i++)
        {
            next=now;
            if(Move(next,i))
            {
                long long next_hash=GetHash(next.card);
                if(next_hash==goal_hash)
                    return next.step;
                if(InsertHash(next_hash))
                {
                    q.push(next);
                }
            }
        }
    }
    return -1;
}

int main()
{
    init_Base();
    int T;
    scanf("%d",&T);
    while(T--)
    {
        init_start();
        printf("%d\n",bfs());
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值