1142 Maximal Clique (25 分) 最大团

A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))

Now it is your job to judge if a given subset of vertices can form a maximal clique.

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.

After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.

Output Specification:
For each of the M queries, print in a line Yes if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal; or if it is not a clique at all, print Not a Clique.

Sample Input:
8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1
Sample Output:
Yes
Yes
Yes
Yes
Not Maximal
Not a Clique

又看了几个有图的博客,才发现这个最大团就是算法课上讲过的最大团,定义晦涩难懂,举几个例子就马上明白了。

其实最大团,就是无向图中无法扩大规模的完全子图。

完全子图:任意两个顶点之间都邻接的图

知道了它的定义,但我同样写了一手垃圾,效率是网上大佬的整整 1 18 \frac{1}{18} 181,别人8ms,我144ms。。。

我的实现如下,输入数据其实都一样,关键是我为了判断两点是否邻接,使用了图的邻接集合表示,可能就是因为这个效率低。

算法都是差不多的,首先判断是否集合中的点全部相互邻接,如果没有,就输出not;之后判断是否是最大团,

#include <bits/stdc++.h>
#define N 205
using namespace std;
//int g[N][N];
map<int,set<int> > ms;
int main()  {
    int ve,e,k;
    scanf("%d%d",&ve,&e);
    for (int i=0;i<e;i++)   {
        int a,b;
        scanf("%d%d",&a,&b);
        ms[a].insert(b);
        ms[b].insert(a);
    }
    scanf("%d",&k);
    for (int i=0;i<k;i++)   {
        int sz,spot=0;
        vector<int> v(N);
        scanf("%d",&sz);
        for (int j=0;j<sz;j++)
            scanf("%d",&v[j]);
        for (int j=0;j<sz;j++)
            for (int k=j+1;k<sz;k++)
                if (ms[v[j]].count(v[k])!=1)   //没有该点
                    {spot=1;break;}
        if (spot)   {printf("Not a Clique\n");continue;}
        for (int j=1;j<=ve;j++)  {
            int cnt=0;
            for (int k=0;k<sz;k++)  {
                if (ms[j].count(v[k]))
                    cnt++;
                else break;
            }
            if (cnt==sz)    {spot=1;break;}
        }
        if (spot)   printf("Not Maximal\n");
        else printf("Yes\n");
    }
    return 0;
}

复杂度:应该是O(n2)

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值