poj 2155 Matrix (二维树状数组)

Matrix
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 26353 Accepted: 9729

Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 
2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2 y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input

1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output

1
0
0
1

Source

POJ Monthly,Lou Tiancheng


题解:这是一个二维的裸树状数组,只是在思考的时候可以转化一下,每次操作是把1转化为0,把0转化为1,其实可以考虑为统计操作次数,然后对2取余,得到答案。


代码如下:

#include <iostream>
//#include <bits/stdc++.h>
#include <cstdio>
#include <cstdlib>

using namespace std;

int bit1[1005][1005];
int n;

int lowbit(int x)
{
    return x&-x;
}

void change(int x1,int x2,int y)
{
    int y1=y;
    for(int i=x1;i>0;i-=lowbit(i))
    {
        for(int j=x2;j>0;j-=lowbit(j))
        {
            bit1[i][j]+=y;
        }
    }
}


int sum1(int x,int y)
{
    int s=0;
    for(int i=x;i<=n;i+=lowbit(i))
        for(int j=y;j<=n;j+=lowbit(j))
            s+=bit1[i][j];
    return s;
}

int main()
{
    int x;
    cin>>x;
    while(x--)
    {
        int t;
        cin>>n>>t;
        for(int i=0;i<=n;i++)
            fill(bit1[i],bit1[i]+n+1,0);
        for(int i=0;i<t;i++)
        {
            char c[100];
            int x1,x2,y1,y2;
            scanf("%s %d %d",c,&x1,&y1);
            if(c[0]=='C')
            {
                scanf("%d %d",&x2,&y2);
                change(x2,y2,1);
                change(x1-1,y2,-1);
                change(x2,y1-1,-1);
                change(x1-1,y1-1,1);
            }
            else
            {
                int ans=sum1(x1,y1);
                printf("%d\n",ans%2);
            }
        }
        if(x>0)
        cout<<endl;
    }
    //cout << "Hello world!" << endl;
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值