Java——各类字符数

Description

从键盘输入一个字符串,程序输出该字符串中的大写英文字母数,小写英文字母数以及非英文字母数

Input

字符串

Output

大写英文字母数
小写英文字母数
非英文字母数

Sample Input

Hello My Dear Friend, I Miss You Very Much!

Sample Output

9
24
10
import java.util.*;

public class Main {

    public static void main(String[] args) {

    Scanner scan = new Scanner(System.in);

    String str = scan.nextLine();

    int small = 0;

    int big = 0;

    int nothing = 0;

    

    for(int i = 0;i<str.length();i++) {

        if(str.charAt(i) >= 'a' && str.charAt(i)<='z')

        {

            small ++;

        }

        if(str.charAt(i) >= 'A' && str.charAt(i) <= 'Z')

        {

            big ++;

        }

        

    }

    nothing = str.length() - big - small;

    System.out.println(big);

    System.out.println(small);

    System.out.println(nothing);

}

}

 

  • 1
    点赞
  • 6
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值