hdu 5087 Revenge of LIS II

Problem Description
In computer science, the longest increasing subsequence problem is to find a subsequence of a given sequence in which the subsequence's elements are in sorted order, lowest to highest, and in which the subsequence is as long as possible. This subsequence is not necessarily contiguous, or unique.
---Wikipedia

Today, LIS takes revenge on you, again. You mission is not calculating the length of longest increasing subsequence, but the length of the second longest increasing subsequence.
Two subsequence is different if and only they have different length, or have at least one different element index in the same place. And second longest increasing subsequence of sequence S indicates the second largest one while sorting all the increasing subsequences of S by its length.
 


 

Input
The first line contains a single integer T, indicating the number of test cases.

Each test case begins with an integer N, indicating the length of the sequence. Then N integer Ai follows, indicating the sequence.

[Technical Specification]
1. 1 <= T <= 100
2. 2 <= N <= 1000
3. 1 <= Ai <= 1 000 000 000
 


 

Output
For each test case, output the length of the second longest increasing subsequence.
 


 

Sample Input
  
  
3 2 1 1 4 1 2 3 4 5 1 1 2 2 2
 


 

Sample Output
  
  
1
3 2
 

 

题意:求次长子序列,LIS算法,dp。

 

代码:

#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<cstring>
#include<algorithm>
#define inf 1<<30
int dp[1100];
int cnt[1100];
int	a[1100];
using namespace std;
int main()
{
	int t,n,i,j,flag,tmp;
	cin>>t;
	while(t--)
	{
		tmp=1;
		for(i=0;i<=1010;i++)
		{
			dp[i]=0;
			cnt[i]=0;
		}
		cin>>n;
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		a[n+1]=inf;
		//LIS
		for(i=1;i<=n+1;i++)
		{
			dp[i]=1;
			cnt[i]=1;
			for(j=1;j<i;j++)
			{
				if(a[i]>a[j]&&dp[i]<dp[j]+1)
				{
					dp[i]=dp[j]+1;
					cnt[i]=1;
				}
				else if(a[i]>a[j]&&dp[i]==dp[j]+1)
					cnt[i]++;
			}
		}
	
		//因为计算到n+1,最长子序列长度会多1,减掉
		//如果以最后一个结尾的最长子序列不止一个,第二长的长度也是最长子序列长度
		if(cnt[n+1]>1)
			printf("%d\n",dp[n+1]-1);
		else
         {
             flag=n+1;
             while(flag>0&&cnt[flag]==1)
             {
                 for(j=flag-1; j>=1; j--)
                 {
                     if(dp[j]+1==dp[flag]&&a[j]<a[flag])
						 break;
                 }
                 flag=j;
             }
			 //验证所有节点的cnt是不是都为1,如果都为1,最长子序列只有一个 则次长子序列长度为最长子序列长度-1
             if(flag==0) 
				 printf("%d\n",dp[n+1]-1-1);
             else 
				 printf("%d\n",dp[n+1]-1);
         }

	}
return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园的建设目标是通过数据整合、全面共享,实现校园内教学、科研、管理、服务流程的数字化、信息化、智能化和多媒体化,以提高资源利用率和管理效率,确保校园安全。 智慧校园的建设思路包括构建统一支撑平台、建立完善管理体系、大数据辅助决策和建设校园智慧环境。通过云架构的数据中心与智慧的学习、办公环境,实现日常教学活动、资源建设情况、学业水平情况的全面统计和分析,为决策提供辅助。此外,智慧校园还涵盖了多媒体教学、智慧录播、电子图书馆、VR教室等多种教学模式,以及校园网络、智慧班牌、校园广播等教务管理功能,旨在提升教学品质和管理水平。 智慧校园的详细方案设计进一步细化了教学、教务、安防和运维等多个方面的应用。例如,在智慧教学领域,通过多媒体教学、智慧录播、电子图书馆等技术,实现教学资源的共享和教学模式的创新。在智慧教务方面,校园网络、考场监控、智慧班牌等系统为校园管理提供了便捷和高效。智慧安防系统包括视频监控、一键报警、阳光厨房等,确保校园安全。智慧运维则通过综合管理平台、设备管理、能效管理和资产管理,实现校园设施的智能化管理。 智慧校园的优势和价值体现在个性化互动的智慧教学、协同高效的校园管理、无处不在的校园学习、全面感知的校园环境和轻松便捷的校园生活等方面。通过智慧校园的建设,可以促进教育资源的均衡化,提高教育质量和管理效率,同时保障校园安全和提升师生的学习体验。 总之,智慧校园解决方案通过整合现代信息技术,如云计算、大数据、物联网和人工智能,为教育行业带来了革命性的变革。它不仅提高了教育的质量和效率,还为师生创造了一个更加安全、便捷和富有智慧的学习与生活环境。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值