对给定的字符串,本题要求你输出最长对称子串的长度。例如,给定"Is PAT&TAP symmetric?",最长对称子串为"s PAT&TAP s",于是你应该输出11。
输入格式:
输入在一行中给出长度不超过1000的非空字符串。
输出格式:
在一行中输出最长对称子串的长度。
输入样例:Is PAT&TAP symmetric?输出样例:
11
数据量不大,使用朴素算法可以解决,直接根据中间值进行判断即可。注意分清字符串的长度是奇是偶??
#include <iostream>
#include <algorithm>
#include <string>
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <vector>
using namespace std;
char a[10010];
int main()
{
while (gets(a))
{
int maxx = 1;
int len = strlen(a);
for(int i = 0; i < len; i ++)
{
// 偶数的时候,初始化temp为1,表示中间的那个数
int temp = 1;
for(int j = 1; j < len; j ++)
{
if (i - j < 0 || i + j >= len || a[i - j] != a[i + j])
break;
temp += 2;
}
maxx = max(maxx, temp);
// 奇数的时候,初始化temp为0,
temp = 0;
for(int j = 1; j < len; j ++)
{
if (i - j + 1 < 0 || i + j >= len || a[i - j + 1] != a[i + j])
break;
temp += 2;
}
maxx = max(maxx, temp);
}
cout << maxx << endl;
}
return 0;
}