Light Oj 1116

Ekka Dokka
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit

Status
Description
Ekka and his friend Dokka decided to buy a cake. They both love cakes and that's why they want to share the cake after buying it. As the name suggested that Ekka is very fond of odd numbers and Dokka is very fond of even numbers, they want to divide the cake such that Ekka gets a share of N square centimeters and Dokka gets a share of M square centimeters where N is odd and M is even. Both N and M are positive integers.

They want to divide the cake such that N * M = W, where W is the dashing factor set by them. Now you know their dashing factor, you have to find whether they can buy the desired cake or not.

Input
Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer W (2 ≤ W < 263). And W will not be a power of 2.

Output
For each case, print the case number first. After that print "Impossible" if they can't buy their desired cake. If they can buy such a cake, you have to print N and M. If there are multiple solutions, then print the result where M is as small as possible.

Sample Input
3
10
5
12
Sample Output
Case 1: 5 2
Case 2: Impossible
Case 3: 3 4

<span style="color:#6600cc;">/****************************************

     author   :   Grant Yuan
     time     :   2014.8.6
     algorithm:   数论
     source   :   Light Oj 1116
     explain  :   如果这个数为奇数则一定不可能;
                  如果为偶数,要保证所得偶数最小,则奇数要最大
                  用原来的数不断除以2,直到所得的数为奇数,再用
                  原数除以奇数便可得到偶数;
                  
*****************************************/

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>

using namespace std;
long long n,a,b,c;

int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++)
    {

        scanf("%lld",&a);
        if(a%2)
            printf("Case %d: Impossible\n",i);
        else{
            c=a;
            while(c%2==0)
            {
             c=c/2;}
            b=a/c;
            printf("Case %d: %lld %lld\n",i,c,b);
        }
    }
    return 0;
}
</span>


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值