输出PATest.

1043 输出PATest(20)(20 分)

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“PATestPATest....”这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按PATest的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:

redlesPayBestPATTopTeePHPereatitAPPT

输出样例:

PATestPATestPTetPTePePee
/*#include<stdio.h>
int main(void)
{
    int P=0,A=0,T=0,e=0,s=0,t=0;
    char c;
    do
    {
        scanf("%c",&c);
        if (c=='P') P++;
        if (c=='A') A++;
        if (c=='T') T++;
        if (c=='e') e++;
        if (c=='s') s++;
        if (c=='t') t++;
    }while(((c>='a')&&(c<='z')) || ((c>='A')&&(c<='Z')));
    do
    {
        if (P>0)
        {
            printf("P");P--;
        }
        if (A>0)
        {
            printf("A");A--;
        }
        if (T>0)
        {
            printf("T");T--;
        }
        if (e>0)
        {
            printf("e");e--;
        }
        if (s>0)
        {
            printf("s");s--;
        }
        if (t>0)
        {
            printf("t");t--;
        }
    }while((P>0)||(A>0)||(T>0)||(e>0)||(s>0)||(t>0));
    printf("\n");
    return 0;
}*/
/*#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{int map[128]={0},c;
while((c=cin.get())!=EOF)map[c]++;
while(map['P']>0||map['A']>0||map['T']>0||map['e']>0||map['s']>0||map['t']>0)
{
    if(map['P']-->0)cout<<'P';
    if(map['A']-->0)cout<<'A';
    if(map['T']-->0)cout<<'T';
    if(map['e']-->0)cout<<'e';
    if(map['s']-->0)cout<<'s';
    if(map['t']-->0)cout<<'t';
}

    return 0;
}
*/
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int main()
{
    char str[100010];
    gets(str);
    char *string="PATest";
    int c[128]={0};//ASCLL码128位
    int count=0;
    int i,j;
    int l1=strlen(str);
    int l2=strlen(string);
    for(i=0;i<l1;i++)
    {
        for(j=0;j<6;j++)
        {
            if(str[i]==string[j])
            {
                c[str[i]-'\0']++;
                count++;
            }
        }
    }
    for(i=0;i<count;i++)
    {
        for(j=0;j<l2;j++)
        {
            if(c[string[j]-'\0']!=0)
            {
                printf("%c",string[j]);
                c[string[j]-'\0']--;
            }
        }
    }
    printf("\n");
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

YuannaY

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值