POJ 1013-Counterfeit Dollar

Counterfeit Dollar
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 40893 Accepted: 13026

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins. 
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs 
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively. 
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.

Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input

1 
ABCD EFGH even 
ABCI EFJK up 
ABIJ EFGH even 

Sample Output

K is the counterfeit coin and it is light. 
 
小结:
    又是不怎么顺利的一天呢....虽然DP依然不尽如人意,但是,除了DP之外我感觉还是相当不错的!小小得意一下...新手做法,如果有点暴力,还请大神海涵...
    个人感觉,还是这种没有限定方法的题目比较有意思...(DP永远是我永远的痛...)
    这道题好像很多人一看都是水题(呵呵),我也就悲催地做了很久...大概的做法是当条件为even的时候,把天平两边的所有元素标记,标记过后的元素一定不是目标,然后我就考虑,目标一定是当天平失衡的时候,出现频率最高的对象,这点是关键。
以下是AC代码:
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<ctype.h>
//#include<math.h>
char map[3][3][15];
int alpha[12];
int main()
{
    char str1[10]="even",str2[10]="up",str3[10]="down";
    int n;
    scanf("%d",&n);
    for(int x=1;x<=n;x++)
    {
        for(int i=0;i<3;i++)
        {
            for(int j=0;j<3;j++)
            {
                scanf("%s",map[i][j]);
            }
        }
        memset(alpha,0,sizeof(alpha));
        for(int i=0;i<3;i++)
        {
            if(!strcmp(str1,map[i][2]))
            {
                for(int m=0;m<2;m++)
                for(int t=0;map[i][m][t]!=0;t++)
                {
                    alpha[map[i][m][t]-'A']=100;
                }
            }
            else if(!strcmp(str2,map[i][2]))
            {
                for(int m=0;m<2;m++)
                for(int t=0;map[i][m][t]!=0;t++)
                {
                    if(isalpha(map[i][m][t])&&alpha[map[i][m][t]-'A']!=100)
                    {
                        if(m)
                        alpha[map[i][m][t]-'A']--;
                        else
                        alpha[map[i][m][t]-'A']++;
                    }
                }
            }
            else
            {
                for(int m=0;m<2;m++)
                for(int t=0;map[i][m][t]!=0;t++)
                {
                    if(isalpha(map[i][m][t])&&alpha[map[i][m][t]-'A']!=100)
                    {
                        if(m)
                        alpha[map[i][m][t]-'A']++;
                        else
                        alpha[map[i][m][t]-'A']--;
                    }
                }
            }
        }
        int t,m=0,flag=0;
        for(int i=0;i<12;i++)
        {
            if(abs(alpha[i])>m&&alpha[i]!=100)
            {
                if(alpha[i]<0)
                    flag=1;
                m=abs(alpha[i]);
                t=i;
            }
            //printf("%c: %d\n",'A'+i,alpha[i]);
        }
        if(flag)
        {
            printf("%c is the counterfeit coin and it is light.\n",'A'+t);
        }
        else
        {
            printf("%c is the counterfeit coin and it is heavy.\n",'A'+t);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值