POJ 3070-Fibonacci

Fibonacci
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10087 Accepted: 7201

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

小结:

        一天有过去了,四月是你的谎言,未闻花名还真是催人泪下啊...

        好了,该说正事了,这道题目,做法题目已经清清楚楚说明了,很简单,基本只要不粗心都能完成!

以下是AC代码:

#include<stdio.h>
#include<string.h>
#include<ctype.h>
#include<algorithm>
#include<map>
#include<vector>
using namespace std;
const int mod=10000;
typedef vector<int>vec;
typedef vector<vec>mat;
typedef long long ll;
mat mul(mat &a,mat &b)
{
    mat c(a.size(),vec(b[0].size()));
    for(int i=0;i<a.size();i++)
    for(int k=0;k<b.size();k++)
    for(int j=0;j<b[0].size();j++)
    {
        c[i][j]=(c[i][j]+a[i][k]*b[k][j])%mod;
    }
    return c;
}
mat pow_mul(mat a,ll num)
{
    mat b(a.size(),vec(a[0].size()));
    for(int i=0;i<a.size();i++)
    b[i][i]=1;
    while(num)
    {
        if(num&1)
        b=mul(b,a);
        a=mul(a,a);
        num>>=1;
    }
    return b;
}
int main()
{
    ll n;
    while(~scanf("%lld",&n)&&n!=-1)
    {
        if(n==0)
        {
            printf("0\n");
            continue;
        }
        mat a(2,vec(2));
        a[0][0]=1;
        a[0][1]=1;
        a[1][0]=1;
        a[1][1]=0;
        a=pow_mul(a,n);
        printf("%d\n",a[1][0]);
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值