UVA 12034-Race

Time Limit: 1000MS Memory Limit: Unknown 64bit IO Format: %lld & %llu

 Status

Description

Download as PDF

Disky and Sooma, two of the biggest mega minds of Bangladesh went to a far country. They ate, coded and wandered around, even in their holidays. They passed several months in this way. But everything has an end. A holy person, Munsiji came into their life. Munsiji took them to derby (horse racing). Munsiji enjoyed the race, but as usual Disky and Sooma did their as usual task instead of passing some romantic moments. They were thinking- in how many ways a race can finish! Who knows, maybe this is their romance!

In a race there are n horses. You have to output the number of ways the race can finish. Note that, more than one horse may get the same position. For example, 2 horses can finish in 3 ways.

  1. Both first
  2. horse1 first and horse2 second
  3. horse2 first and horse1 second

Input 

Input starts with an integer  T (  $ \le$1000), denoting the number of test cases. Each case starts with a line containing an integer  n (  1$ \le$n$ \le$1000).

Output 

For each case, print the case number and the number of ways the race can finish. The result can be very large, print the result modulo 10056.

Sample Input 

3
1
2
3

Sample Output 

Case 1: 1
Case 2: 3
Case 3: 13



Source

Root :: AOAPC II: Beginning Algorithm Contests (Second Edition) (Rujia Liu) :: Chapter 10. Maths ::  Examples
Root :: Prominent Problemsetters ::  Md. Mahbubul Hasan
Root :: AOAPC I: Beginning Algorithm Contests -- Training Guide (Rujia Liu) :: Chapter 2. Mathematics :: Counting :: Exercises: Intermediate


小结:

    大概想法是递推,至于为什么是递推,因为题目分类就是递推(看到这里不要打我==),对于递归的想法,我感觉,对于每种情况的分类讨论是解决这类问题的关键。

就拿这道题目来说,在现有的名次中插入新个体是这种题目的常见思路。

dp[i][j]=i个人组成的所有的名次的种类数目,那么对应的每个新插入的个体,对应2种情况:(1)增加现有的名次总数 (2)加入现有的任意一个名次中。

然后就会有以下递推方程:dp[i][j]=i==j?dp[i-1][j-1]*j:(dp[i-1][j]+dp[i-1][j-1])*j;

以下是AC代码:

//111,112,121,211,122,212,221,123,132,213,231,312,321
//当n的值为3的时候,排名的种数为13
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
const int mod=10056;
int dp[1005][1005];
void solve()
{
    int ans,n;
    int t;
    scanf("%d",&t);
    for(int m=1;m<=t;m++)
    {
        scanf("%d",&n);
        ans=0;
        for(int i=1;i<=n;i++)
        {
            ans+=dp[n][i];
            ans=ans%mod;
        }
        printf("Case %d: %d\n",m,ans);
    }
}
int main()
{
    int n;
    int mod=10056;
    memset(dp,0,sizeof(dp));
    dp[0][0]=1;
    for(int i=1;i<=1000;i++)
    {
        for(int j=1;j<=i;j++)
        {
            dp[i][j]=i==j?dp[i-1][j-1]*j:(dp[i-1][j]+dp[i-1][j-1])*j;
            dp[i][j]=dp[i][j]%mod;
        }
    }
    solve();
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值