20170717 A. Maximum Element In A Stack

The 2018 ACM-ICPC Chinese Collegiate Programming Contest

As an ACM-ICPC newbie, Aishah is learning data structures in computer science. She has already known that a stack, as a data structure, can serve as a collection of elements with two operations:

  • push, which inserts an element to the collection, and
  • pop, which deletes the most recently inserted element that has not yet deleted.

Now, Aishah hopes a more intelligent stack which can display the maximum element in the stack dynamically. Please write a program to help her accomplish this goal and go through a test with several operations.

Aishah assumes that the stack is empty at first. Your program will output the maximum element in the stack after each operation. If at some point the stack is empty, the output should be zero.

Input Format

The input contains several test cases, and the first line is a positive integer TT indicating the number of test cases which is up to 5050.

To avoid unconcerned time consuming in reading data, each test case is described by seven integers n~(1\le n\le 5 \times 10^6)n (1≤n≤5×106), pp, qq, m~(1\le p, q, m\le 10^9)m (1≤p,q,m≤109), SASA, SBSB and SC~(10^4 \le SA, SB, SC\le 10^6)SC (104≤SA,SB,SC≤106).The integer nn is the number of operations, and your program should generate all operations using the following code in C++.

 

 

1

int n, p, q, m;

2

unsigned int SA, SB, SC;

3

unsigned int rng61(){

4

    SA ^= SA << 16;

5

    SA ^= SA >> 5;

6

    SA ^= SA << 1;

7

    unsigned int t = SA;

8

    SA = SB;

9

    SB = SC;

10

    SC ^= t ^ SA;

11

    return SC;

12

}

13

void gen(){

14

    scanf("%d%d%d%d%u%u%u", &n, &p, &q, &m, &SA, &SB, &SC);

15

    for(int i = 1; i <= n; i++){

16

        if(rng61() % (p + q) < p)

17

            PUSH(rng61() % m + 1);

18

        else

19

            POP();

20

    }

21

}

The procedure PUSH(v) used in the code inserts a new element with value vv into the stack and the procedure POP() pops the topmost element in the stack or does nothing if the stack is empty.

Output Format

For each test case, output a line containing Case #x: y, where xx is the test case number starting from 11, and yy is equal to \mathop{\oplus}\limits_{i = 1}^{n}{\left(i \cdot a_i\right)}i=1⊕n​(i⋅ai​)where a_iai​ is the answer after the ii-th operation and \oplus⊕ means bitwise xor.

Hint

The first test case in the sample input has 44operations:

  • POP();
  • POP();
  • PUSH(1);
  • PUSH(4).

The second test case also has 44 operations:

  • PUSH(2);
  • POP();
  • PUSH(1);
  • POP().

样例输入

2
4 1 1 4 23333 66666 233333
4 2 1 4 23333 66666 233333

样例输出

Case #1: 19
Case #2: 1

中文翻译:

现在有一个栈,初始为空。接下来有若干次操作,每次可能向栈顶 push 一个正整数,也可能 pop 掉
栈顶元素。
你需要在每次操作之后计算出栈内所有元素的最大值。如果栈为空则认为此时最大值是 0。
为了避免输入文件过大,所有操作会使用 rng61 算法生成。同时为了避免输出文件过大,你只需要
输出一个数:表示每次操作之后的答案与下标乘积的异或和。
输入格式
第一行包含一个整数 T,表示测试数据的组数。
接下来依次描述 T 组测试数据,为了减少读入量,采用如下的方式来给出数据。
对于每组测试数据:一行给出了 7 个整数依次为 n; p; q; m; SA; SB; SC。其中 n 表示总的操作次数,
你的程序可以使用如下所示的 C++ 代码生成所有的操作。
(代码见原题面)
在这份代码中, PUSH(v) 表示向栈中插入一个新的元素,它的值为 v。 POP() 表示弹出栈顶元素;如
果当前栈为空,则什么也不操作(即:没有东西可以弹出)。
输出格式
对于每组测试数据,输出一行信息 "Case #x: y"(不含引号),其中 x 表示这是第 x 组测试数据,
y 等于  i=1到n的(i · ai)的异或和,其中 ai 表示第 i 次操作后的答案

 

题目给出了个rng61算法,不需要懂,直接在题目的代码上补全就行,

要自己实现

PUSH(rng61() % m + 1);

POP();

先要自己建一个栈,最后是算异或和,运算符是^

 


#include <iostream>

using namespace std;
int stak[5000001],top;
int n, p, q, m;
unsigned int SA, SB, SC;
unsigned int rng61()
{
    SA ^= SA << 16;
    SA ^= SA >> 5;
    SA ^= SA << 1;
    unsigned int t = SA;
    SA = SB;
    SB = SC;
    SC ^= t ^ SA;
    return SC;
}
long long gen()
{
    scanf("%d%d%d%d%u%u%u", &n, &p, &q, &m, &SA, &SB, &SC);
    long long ans;
    ans=0,top=0;
    for(int i = 1; i <= n; i++)
    {
        if(rng61() % (p + q) < p)
        {
            top++;
            stak[top]=rng61()%m+1;
            stak[top]=max(stak[top],stak[top-1]);
        }
        else
            if(top-1>0)
            top=top-1;
            else
            top=0;
        ans=ans^1LL*i*stak[top];

    }
    return ans;
}
int main()
{
    int t;
    scanf("%d",&t);
    for(int i=1; i<=t; i++)
    {
        printf("Case #%d: %lld\n",i,gen());
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值