[POJ3268](最短路dijkstra+反向存图)Silver Cow Party

POJ3268Silver Cow Party

题目

ne cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1…N is going to attend the big cow party to be held at farm X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti(1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input

Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2… M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.

Output

Line 1: One integer: the maximum of time any one cow must walk.

Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint

Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

思路

N<=1000,用Floyd的话会TLE,所以用dijkstra算法,算x到各点与各点到x点的距离之和。因为算来回的距离之和,如果要算其他点到x的距离话就需要算N-1次,所以可以在第二次之前反向存图,继续算x到各点距离,减少时间。

代码

裸Dijkstra算法

#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<ctype.h>
#include<queue>
#include<set>
#include<stack>
#include<cmath>
const int maxn=0x3f3f3f3f;
const int minn=0xc0c0c0c0;
const int inf=99999999;
using namespace std;
int res[2][1010],dis[1010][1010],vis[1010];
int n,m,x;
void dij(int p)
{
	int i,j,k,u,min1;
	memset(vis,0,sizeof(vis));
	vis[x]=1;
	for(i=1;i<=n;i++)
		res[p][i]=dis[x][i];
	for(i=1;i<=n;i++)
	{
		min1=inf;
		for(j=1;j<=n;j++)
			if(vis[j]==0 && res[p][j]<min1)
			{
				u=j;
				min1=res[p][j];
			}
		vis[u]=1;
		for(k=1;k<=n;k++)
			if(dis[u][k]<inf)
				res[p][k]=min(res[p][k],res[p][u]+dis[u][k]);
	}
	return;
}
int main()
{
	ios::sync_with_stdio(false);
	cin.tie(0);cout.tie(0);
	cin>>n>>m>>x;
	int i,j;
	for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
			if(i==j) dis[i][j]=0;
			else dis[i][j]=inf;
	for(i=1;i<=m;i++)
	{
		int a,b,c;
		cin>>a>>b>>c;
		dis[a][b]=c;
	}
	dij(0);
	for(i=1;i<=n;i++)
		for(j=i+1;j<=n;j++)
			swap(dis[i][j],dis[j][i]);
	dij(1);
	int ans=res[0][1]+res[1][1];
	for(i=2;i<=n;i++)
		ans=max(ans,res[0][i]+res[1][i]);
	cout<<ans<<endl;
	return 0;
}

堆优化代码

#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<ctype.h>
#include<queue>
#include<set>
#include<stack>
#include<cmath>
const int maxn=0x3f3f3f3f;
const int minn=0xc0c0c0c0;
const int inf=99999999;
using namespace std;
int res[2][1010],dis[1010][1010],vis[1010];
int n,m,x;
void dij(int p)
{
	int i,j,k,u,min1;
	priority_queue<pair<int,int>,vector<pair<int,int> >,greater<pair<int,int> > > que;
	memset(vis,0,sizeof(vis));
	for(i=1;i<=n;i++)
		res[p][i]=dis[x][i];
	que.push(make_pair(0,x));
	while(!que.empty())
	{
		int i;
		int pre=que.top().second;
		que.pop();
		if(vis[pre]==1) continue;
		vis[pre]=1;
		for(i=1;i<=n;i++)
			if(dis[pre][i]<inf)
				if(res[p][i]>=res[p][pre]+dis[pre][i])
				{
					res[p][i]=res[p][pre]+dis[pre][i];
					que.push(make_pair(res[p][i],i));
				}		
	}
	return;
}
int main()
{
	ios::sync_with_stdio(false);
	cin.tie(0);cout.tie(0);
	cin>>n>>m>>x;
	int i,j;
	for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
			if(i==j) dis[i][j]=0;
			else dis[i][j]=inf;
	for(i=1;i<=m;i++)
	{
		int a,b,c;
		cin>>a>>b>>c;
		dis[a][b]=c;
	}
	dij(0);
	for(i=1;i<=n;i++)
		for(j=i+1;j<=n;j++)
			swap(dis[i][j],dis[j][i]);
	dij(1);
	int ans=res[0][1]+res[1][1];
	for(i=2;i<=n;i++)
		ans=max(ans,res[0][i]+res[1][i]);
	cout<<ans<<endl;
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值