[POJ3259](最短路spfa)Wormholes

POJ3259Wormholes

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2… M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2… M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1… F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

分析:

spfa+链式前向星,当一个点入队的次数达到n的时候,表明存在负环。

代码:

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
#include<iostream>
#include<string.h>
#include<ctype.h>
#include<queue>
#include<set>
#include<stack>
#include<cmath>
const int maxn=0x3f3f3f3f;
const int minn=0xc0c0c0c0;
const int k=1e4;
#define inf 99999999
using namespace std;
struct point
{
	int next,to,w;
}maze[k<<2];
int head[k],len=0,n;
int spfa()
{
	queue<int> que;
	int vis[k]={0},num[k]={0},dis[k];
	int j;
	for(j=1;j<=n;j++)
		dis[j]=inf;
	dis[1]=0;
	vis[1]=1;
	num[1]=1;
	que.push(1);
	while(!que.empty())
	{
		int pre=que.front(),i;
		que.pop();
		vis[pre]=0;
		for(i=head[pre];i;i=maze[i].next)
		{
			if(dis[maze[i].to]>dis[pre]+maze[i].w)
			{
				dis[maze[i].to]=dis[pre]+maze[i].w;
				if(!vis[maze[i].to])
				{
					num[maze[i].to]++;
					if(num[maze[i].to]>=n)
						return 1;
					vis[maze[i].to]=1;
					que.push(maze[i].to);
				}
			}			
		}
	}
	return 0;
}
void add(int a,int b,int c)
{
	maze[++len]={head[a],b,c};
	head[a]=len;
} 
int main()
{
	ios::sync_with_stdio(false);
	cin.tie(0);cout.tie(0);
	int t;
	cin>>t;
	while(t--)
	{
		int m,w,i,j;
		memset(head,0,sizeof(head));
		cin>>n>>m>>w;
		int a,b,c;
		for(i=1;i<=m;i++)
		{
			cin>>a>>b>>c;
			add(a,b,c);
			add(b,a,c);
		}
		for(i=1;i<=w;i++)
		{
			cin>>a>>b>>c;
			add(a,b,-c);
		}
		if(spfa())
			cout<<"YES"<<endl;
		else
			cout<<"NO"<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值