PAT-甲级-1001

1001. A+B Format (20)

Calculate a + b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input

Each input file contains one test case. Each case contains a pair of integers a and b where -1000000 <= a, b <= 1000000. The numbers are separated by a space.

Output

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input
-1000000 9
Sample Output
-999,991
【解析】
这道题呢就是让你算加法,然后按照每三位数进行输出,所以我们这里就可以用到除余和除法就可以了。超过一百万的我们单独放一位如果是四位数我们就这么放4,123,可以分一下数据的范围小于1000的直接输出,大于一前小于100万的,就按照前面除1000有几位输出就输出几位。注意负数的话先要输出一个负号。
#include <iostream>
#include<cstdio>
using namespace std;
int main(){
    int a,b;
    int sum=0;
    while(cin>>a>>b){
        sum=a+b;
        if(sum<0){
            sum=-sum;
            cout<<"-";
        }
        if(sum<1000)
        cout<<sum;
        else if(sum>=1000&&sum<1000000)
            printf("%d,%03d",(sum/1000),sum%1000);
        else if(sum>=1000000)
            printf("%d,%03d,%03d",sum/1000000,((sum%1000000)/1000),sum%1000);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值