PAT-甲级1009

1009. Product of Polynomials (25)

This time, you are supposed to find A*B where A and B are two polynomials.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10, 0 <= NK < ... < N2 < N1 <=1000.

Output Specification:

For each test case you should output the product of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate up to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 3 3.6 2 6.0 1 1.6
【解析】
因为数据比较下所有我们可以直接模拟,然后注意下多项式的运算就可以了。
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
int main(){
	double a[1001]={0.0},b[2001]={0.0},k;
	int  m,n,i,j,count=0;
	scanf("%d",&n);
	for(i=0;i<n;i++){
		scanf("%d %lf",&m,&k);//存储数据,下标存储的是指数,值存的是系数
		a[m]=k;
	}
	scanf("%d",&n);
	for(i=0;i<n;i++){
		scanf("%d %lf",&m,&k);
		for(j=0;j<=1000;j++){
			if(a[j]!=0.0){
				b[j+m]+=a[j]*k;//下标代表指数相加,值代表签名的系数相乘了
			}
		}
	}
	for(i=0;i<=2000;i++){
		if(b[i]!=0.0)//统计个数
			count++;
	}
	printf("%d",count);
	for(i=2000;i>=0;i--){
		if(b[i]!=0.0)
			printf(" %d %.1f",i,b[i]);//按格式输出
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值