ZCMU-1231-Antimonotonicity

1231: Antimonotonicity

Time Limit: 10 Sec   Memory Limit: 128 MB
Submit: 33   Solved: 10
[ Submit][ Status][ Web Board]

Description

I have a sequence Fred of length n comprised of integers between 1 and n inclusive. The elements of Fred are pairwise distinct. I want to find a subsequence Mary of Fred that is as long as possible and has the property that:

   Mary[0] > Mary[1] < Mary[2] > Mary[3] < ...

Input

The first line of input will contain a single integer T expressed in decimal with no leading zeroes. T will be at most 50. T test cases will follow.

Each test case is contained on a single line. A line describing a test case is formatted as follows:

   n Fred[0] Fred[1] Fred[2] ... Fred[n-1].

where n and each element of Fred is an integer expressed in decimal with no leading zeroes. No line will have leading or trailing whitespace, and two adjacent integers on the same line will be separated by a single space. n will be at most 30000.

 

Output

For each test case, output a single integer followed by a newline --- the length of the longest subsequence Mary of Fred with the desired properties.

 

Sample Input

4
5 1 2 3 4 5
5 5 4 3 2 1
5 5 1 4 2 3
5 2 4 1 3 5

Sample Output

1
2
5
3

【解析】
这道题的意思就是让我们判断一个序列满足大于小于,大于小于排列的数有几个可以不用连续的。也就是说第一个要
大于第二个,大二个要小于第三个,第三个大于第四个,第四个小于第五个。还有就是如果没有满足的,那就输出1,
表示只有一个。所以我们这里就用flag来进行判断该到大于小于的。
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
using namespace std;
int main()
{
    int t,n,i,p,q,flag,count1;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        scanf("%d",&p);
        flag=1;
        count1=1;
        for(i=1;i<n;i++)
            {
                scanf("%d",&q);
                if(flag==1)
                {
                  if(q<p)
                  {
                      count1++;
                      flag=0;
                  }
                  p=q;
                }
                else
                {
                    if(q>p)
                    {
                        count1++;
                        flag=1;
                    }
                    p=q;
                }
            }
            printf("%d\n",count1);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值