ZCMU-1431-Epic Game

1431: Epic Game

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 44   Solved: 34
[ Submit][ Status][ Web Board]

Description

Simon and Antisimon play a game. Initially each player receives one fixed positive integer that doesn't change throughout the game. Simon receives number a and Antisimon receives number b. They also have a heap of n stones. The players take turns to make a move and Simon starts. During a move a player should take from the heap the number of stones equal to the greatest common divisor of the fixed number he has received and the number of stones left in the heap. A player loses when he cannot take the required number of stones (i. e. the heap has strictly less stones left than one needs to take).

Your task is to determine by the given ab and n who wins the game.

Input

The only string contains space-separated integers ab and n (1 ≤ a, b, n ≤ 100) — the fixed numbers Simon and Antisimon have received correspondingly and the initial number of stones in the pile.

Output

If Simon wins, print "0" (without the quotes), otherwise print "1" (without the quotes).

Sample Input

3 5 9
1 1 100

Sample Output

0
1

HINT


The greatest common divisor of two non-negative integers  a  and  b  is such maximum positive integer  k , that  a  is divisible by  k  without remainder and similarly,  b  is divisible by  k  without remainder. Let gcd (a, b)  represent the operation of calculating the greatest common divisor of numbers  a  and  b . Specifically,  gcd (x, 0) = gcd(0, x) = x .

In the first sample the game will go like that:

· Simon should take  gcd (3, 9) = 3  stones from the heap. After his move the heap has  6  stones left.

· Antisimon should take  gcd (5, 6) = 1  stone from the heap. After his move the heap has  5  stones left.

· Simon should take  gcd (3, 5) = 1  stone from the heap. After his move the heap has  4  stones left.

· Antisimon should take  gcd (5, 4) = 1  stone from the heap. After his move the heap has  3  stones left.

· Simon should take  gcd (3, 3) = 3  stones from the heap. After his move the heap has  0  stones left.

· Antisimon should take  gcd (5, 0) = 5  stones from the heap. As  0 < 5 , it is impossible and Antisimon loses.

In the second sample each player during each move takes one stone from the heap. As  n  is even, Antisimon takes the last stone and Simon can't make a move after that.

【解析】
这道题其实就是两个人来玩游戏,看了下面的HINT部分大家应该就会明白了,每次移动的石头就是最大公约数刚开始先n,k求最大公约数,之后就是k减去移动的石头,然后再m和k求最大公约数。第一个人胜利的就打印0,第二个人就打印1。
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
int gcd(int a,int b)
{
    int temp;
    while(b!=0)
    {
        temp=a%b;
        a=b;
        b=temp;
    }
    return a;
}
int main()
{
 int n,m,k,p,q;
 while(~scanf("%d%d%d",&n,&m,&k))
 {
     p=0;
     while(k>=0)
     {
         if(p!=0)
         {
             q=gcd(m,k);
         }
         else
         {
             q=gcd(n,k);
         }
         k=k-q;
         p=!p;
     }
     printf("%d\n",p);
 }
 return 0;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值