ZCMU-1793-Snap

1793: Problem D - Snap

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 6   Solved: 4
[ Submit][ Status][ Web Board]

Description

Problem D - Snap

Snap is a 2-player card game. The deck of cards contains several of each type of card. Initially each player has one half of the deck, in some random sequence, face down in a pile, and plays them in sequence from top to bottom, placing each card face-up in another pile. When the face-down pile is exhausted, the face-up pile is turned over to become the face-down pile and play continues.

The two players play their cards concurrently and synchronously. That is, each places a card face up at exactly the same time. If two cards turned up at the same time are the same type, each player calls "Snap!" and the player who calls first takes the other's face-up pile and places it on top of his or her own.

Play proceeds until one player has all the cards. This player is the winner.

Your job is to simulate a game of snap to determine whether it will end within 1000 turns and, if so, to determine the winner.

Each type of card is denoted by a single letter or digit. The first line of input Jane's initial pile of cards, from top to bottom. The second line of input is John's initial pile. Jane and John start with the same number of cards; not more than 50 each.

During play, whenever it comes time to call "Snap!" the builtin function "random" is used to determine who calls first: if the expression

   random()/141%2           {in C or C++}

   random div 141 mod 2     {in Pascal; see note below}

yields 0, Jane calls first; otherwise John calls first. Whenever Jane calls first, print "Snap! for Jane: " followed by Jane's face-up pile, from top to bottom. Whenever John calls first, print "Snap! for John: " followed by John's face-up pile. If the game ends, print "John wins." or "Jane wins.", whichever is appropriate. If the game does not end when each player has turned over 1000 cards, print "Keeps going and going ..."

Input

Output

Sample Input

ABCDA
CBADC

Sample Output

Snap! for Jane: BCBA
Snap! for Jane: DADCBCBA
Snap! for John: CBAC
Snap! for John: ADADCBAC
John wins.

【解析】
这道题的意思其实就是给你两个人的牌数,以及牌的种类,如果两个人出牌的种类不一样就放桌子上,如果一样就把
某人桌上的牌给另外一个人,那这个某人怎么判断呢,根据(rand()/141)%2如果为0就把john桌上的牌给jane,这里举
个例子ABCDA和CBADC,再遇到第2张牌的时候相同了,就把CBADC中的CB放到AB上面,注意是这么放的把C放到AB上面,
再把B放到ABC的上面,输出是从最顶上开始输出。这样我们可以用vector来做,删除和插入和牌的移动就比较简单了。
一直到一个人的手牌为0,那个人就输了,还有就是如果一个人手上的手牌没有了,就把桌上的牌补充为手牌,这样一直
做,如果次数到了1000次就输出Keeps going and going ... 这里有一个地方学到的挺好的就是goto的应用,起来可以
很方便。
                                                                              
#include<iostream>
#include<cstdio>
#include<vector>
#include<cstdlib>
#include<algorithm>
using namespace std;
vector<char> a,b,c,d;
int main()
{
    int i,n,m,len;
    char s[2017];
    a.clear();
    b.clear();
    c.clear();
    d.clear();
    scanf("%s",s);
    for(i=0;s[i]!='\0';i++)
        a.push_back(s[i]);//输入牌的种类
    scanf("%s",s);
    for(i=0;s[i]!='\0';i++)
        b.push_back(s[i]);
    vector<char>::iterator it;
    for(i=0;i<1000;i++)
    {
        if(a.size()==0)
        {
            printf("John wins.\n");
            goto out;
        }//当Jane手牌为0了
       else if(b.size()==0)
        {
           printf("Jane wins.\n");
           goto out;
        }
        len=min(a.size(),b.size());//手牌数量以小的为准进行比较
        while(len--)
        {
        if(a.size()==0)
        {
            printf("John wins.\n");
            goto out;
        }
       else if(b.size()==0)
        {
           printf("Jane wins.\n");
           goto out;
        }
        c.push_back(a.front());
        d.push_back(b.front());
        if(a.front()==b.front())//比较两个手牌一不一样
        {
            m=(rand()/141)%2;//决定是谁Snap
            if(m==0)
            {
                c.insert(c.end(),d.begin(),d.end());
                d.clear();
                n=0;
                for(it=c.begin();it!=c.end();it++)
                {
                    s[n++]=*it;
                }
                printf("Snap! for Jane: ");
                while(n--)
                    printf("%c",s[n]);
                printf("\n");
            }
            else
            {
                d.insert(d.end(),c.begin(),c.end());
                c.clear();
                n=0;
                for(it=d.begin();it!=d.end();it++)
                {
                    s[n++]=*it;
                }
                printf("Snap! for John: ");
                while(n--)
                    printf("%c",s[n]);
                printf("\n");
            }
        }
        a.erase(a.begin());//删除第一个元素,每比较一次删除一次
        b.erase(b.begin());
    }
    if(a.empty())
        a=c,c.clear();//如果手牌空了,就把桌上的牌给他
    if(b.empty())
        b=d,d.clear();
    }
    printf("Keeps going and going ...\n");
    out:;
    return 0;
}

在探索智慧旅游的新纪元中,一个集科技、创新与服务于一体的整体解决方案正悄然改变着我们的旅行方式。智慧旅游,作为智慧城市的重要分支,旨在通过新一代信息技术,如云计算、大数据、物联网等,为游客、旅游企业及政府部门提供无缝对接、高效互动的旅游体验与管理模式。这一方案不仅重新定义了旅游行业的服务标准,更开启了旅游业数字化转型的新篇章。 智慧旅游的核心在于“以人为本”,它不仅仅关注技术的革新,更注重游客体验的提升。从游前的行程规划、信息查询,到游中的智能导航、个性化导览,再到游后的心情分享、服务评价,智慧旅游通过构建“一云多屏”的服务平台,让游客在旅游的全过程中都能享受到便捷、个性化的服务。例如,游客可以通过手机APP轻松定制专属行程,利用智能语音导览深入了解景点背后的故事,甚至通过三维GIS地图实现虚拟漫游,提前感受目的地的魅力。这些创新服务不仅增强了游客的参与感和满意度,也让旅游变得更加智能化、趣味化。 此外,智慧旅游还为旅游企业和政府部门带来了前所未有的管理变革。通过大数据分析,旅游企业能够精准把握市场动态,实现旅游产品的精准营销和个性化推荐,从而提升市场竞争力。而政府部门则能利用智慧旅游平台实现对旅游资源的科学规划和精细管理,提高监管效率和质量。例如,通过实时监控和数据分析,政府可以迅速应对旅游高峰期的客流压力,有效预防景区超载,保障游客安全。同时,智慧旅游还促进了跨行业、跨部门的数据共享与协同合作,为旅游业的可持续发展奠定了坚实基础。总之,智慧旅游以其独特的魅力和无限潜力,正引领着旅游业迈向一个更加智慧、便捷、高效的新时代。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值