PKU2456二分查找

原题http://poj.org/problem?id=2456

Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6001 Accepted: 2989

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).  

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C  

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

Hint

OUTPUT DETAILS:  

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.  

Huge input data,scanf is recommended.

Source

//题目意思,求两头最近的牛之间的最大距离
//方法。直接对距离进行二分,找出答案

#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
//#include <limlits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <stack>
#include <queue>
#include <deque>
#include <set>
#include <vector>
#include <map>
using namespace std;
#define N 100005
int x[N];
int n,c;

bool ok(int dis){
	int i;
	int next;
	int last = 0;
	for(i=1;i<c;i++){//要使所有的牛都要满足
		next = last+1;
		while(next<n && x[next]-x[last]<dis){//不断的扩大
			next++;
		}
		if(next >= n){//因为此时牛的数量还没有满,说明了不能对所有的牛都满足,所以这个距离太大了
			return false;
		}
		last = next;
	}
	return true;
}
int main(){
	int i;

	while(~scanf("%d%d",&n,&c)){
		memset(x,0,sizeof(x));
		for(i=0;i<n;i++){
			scanf("%d",&x[i]);
		}
		sort(x,x+n);
		int l = 0;
		int r = 1000000000;//可能的距离
		//int mid = l+(r-l)/2;
		int mid;
		while(r-l > 1){//不断的缩小距离,直到距离之间的距离为一
			mid = (l+r)/2;
			if(ok(mid) == true){//如果这个距离满足,说明了,还可以继续往大的来找
				l = mid;
			}
			else{
				r = mid;
			}
		}
		printf("%d\n",l);
	}

	return 0;
}


 

评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值