简单的二分HDU2199

原题http://acm.hdu.edu.cn/showproblem.php?pid=2199

Can you solve this equation?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8441    Accepted Submission(s): 3902


Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.


 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);


 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.


 

Sample Input
  
  
2 100 -4


 

Sample Output
  
  
1.6152 No solution!


 

Author
Redow
//一道简单的二分。首先判断下在那些范围是一定有解的
//然后不断的缩小范围就可以了
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <stack>
#include <queue>
#include <deque>
#include <vector>
#include <set>
#include <map>
using namespace std;
__int64 Y;
const double d = 1e-8;

double f(double m){
	if(Y-(8*m*m*m*m+7*m*m*m+2*m*m+3*m+6)>=1e-20){
		return 1;
	}
	else{
		return 0;
	}
}

//d//ouble f1(double x){/
//	return (8*x*x*x*x+7*x*x*x+2*x*x+3*x+6-Y);
//}

int main(){
	int T;

	while(~scanf("%d",&T)){
		while(T--){
			scanf("%I64d",&Y);
			if(Y<6 || Y>807020306){
				printf("No solution!\n");
				continue;
			}
			else{
				double l = 0.0;
				double r = 100.0;
				int flag = 0;
				while(r-l > d){
					double mid = (l+r)/2;
					if(f(mid) == 1){
						l = mid;
					}
					else{
						r = mid;
					}
				}
				printf("%.4lf\n",l);
				//if(flag == 0){
				//	printf("No solution!\n");
				//}
			}
		}
	}

	return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值