进制转换(高级版^^)

输入一个十进制数N,将它转换成R进制数输出。

Input

输入数据包含多个测试实例,每个测试实例包含两个整数N(32位整数)和R(2<=R<=16, R<>10)。

Output

为每个测试实例输出转换后的数,每个输出占一行。如果R大于10,则对应的数字规则参考16进制(比如,10用A表示,等等)。

Sample Input

7 2
23 12
-4 3

Sample Output

111
1B
-11

 

#include <stdio.h>
#include <string.h>
#include <deque>
#include <algorithm>
#include <iostream>
using namespace std;
int fun(int n,int r)
{
    if(n==0)
        return 1;
    fun(n/r,r);
    if(n%r>=10)
    {
        int m=n%r-10;
        char c='A';
        printf("%c",c+m);
    }
    else
        printf("%d",n%r);
    return n;
}
int main()
{
    int n,r;
    while(~scanf("%d%d",&n,&r))
    {
        if(n>0)
            fun(n,r);
        else if(n==0)
            printf("0");
        else
        {
            printf("-");
            fun(-n,r);
        }
        puts("");
    }
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值