A - Cats and Fish (2017年ICPC中国大陆区域赛真题)

There are many homeless cats in PKU campus. They are all happy because the students in the cat club of PKU take good care of them. Li lei is one of the members of the cat club. He loves those cats very much. Last week, he won a scholarship and he wanted to share his pleasure with cats. So he bought some really tasty fish to feed them, and watched them eating with great pleasure. At the same time, he found an interesting question:

There are m fish and n cats, and it takes ci minutes for the ith cat to eat out one fish. A cat starts to eat another fish (if it can get one) immediately after it has finished one fish. A cat never shares its fish with other cats. When there are not enough fish left, the cat which eats quicker has higher priority to get a fish than the cat which eats slower. All cats start eating at the same time. Li Lei wanted to know, after x minutes, how many fish would be left.

Input

There are no more than 20 test cases.

For each test case:

The first line contains 3 integers: above mentioned m, n and x (0 < m <= 5000, 1 <= n <= 100, 0 <= x <= 1000).

The second line contains n integers c1,c2 … cn,  ci means that it takes the ith cat ci minutes to eat out a fish ( 1<= ci <= 2000).

Output

For each test case, print 2 integers p and q, meaning that there are p complete fish(whole fish) and q incomplete fish left after x minutes.

Sample Input

2 1 1
1
8 3 5
1 3 4
4 5 1
5 4 3 2 1
Sample Output

1 0
0 1
0 3
 

题意:有m条鱼,n只猫,x分钟,给出每只猫吃一条鱼花费的时间,一条鱼只能被一只猫吃,不存在抢食物的情况,问最后剩余的鱼中,完整的是几条,不完整的是几条。

思路:先将每条猫的速度从小到大排序,尽可能多吃几条鱼。按照分钟来遍历每一条猫,用一个数组b来记录这条猫的状态 ,1代表正在吃鱼,0代表不在吃鱼,只有当时间整除猫的速度才能吃完一条鱼,每次吃完一条鱼就减1,最后输出剩余的鱼数就是剩余完整的鱼,然后在遍历b数组,求出不完整的鱼。

 

#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
#include<vector>
#include<algorithm>
#include<map>
using namespace std;
#define ll long long
#define inf 0x3f3f3f3f
const int mod=1e9+10;
const int M=1e4 + 10;
int a[110], b[110];
int main()
{
    int n, m, x, p, q;
    while(cin>>m>>n>>x){
        p = 0, q = 0;
        int mm = m;
        for (int i = 0; i < n; i++)
            cin >> a[i];
        sort(a, a + n);
        memset(b, 0, sizeof(b));
        for (int i = 1; i <= x; i++){
            if(m<=0)
                break;
            for (int j = 0; j < n; j++){
                if(m<=0)
                    break;
                if(b[j] == 0)//猫不在吃鱼
                    m--;
                if (i % a[j] == 0){//吃完一条鱼
                    b[j] = 0;
                }
                else{
                    b[j] = 1;
                }
            }
        }
        for (int i = 0; i < n; i++){
            if(b[i] == 1)
                q++;//多少鱼正在吃
        }
        cout << m << " " << q << endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值