HDU 2123 An easy problem

An easy problem

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3474    Accepted Submission(s): 2452


Problem Description
In this problem you need to make a multiply table of N * N ,just like the sample out. The element in the i th row and j th column should be the product(乘积) of i and j.
 

Input
The first line of input is an integer C which indicate the number of test cases.

Then C test cases follow.Each test case contains an integer N (1<=N<=9) in a line which mentioned above.
 

Output
For each test case, print out the multiply table.
 

Sample Input
  
  
2 1 4
 

Sample Output
  
  
1 1 2 3 4 2 4 6 8 3 6 9 12 4 8 12 16
Hint
There is no blank space at the end of each line.
 

思路:先打表,然后再控制输出就行了。

AC代码:

#include<iostream>
using namespace std;
int a[10][10];
int main()
{
	int t,i,j,n;
	for(i=1;i<10;i++)
	{a[1][i]=a[i][1]=i;}
	for(i=2;i<10;i++)
	  for(j=2;j<10;j++)
	    a[i][j]=a[i][1]*a[1][j];
	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{
			scanf("%d",&n);
			for(i=1;i<=n;i++)
			{
				for(j=1;j<=n;j++)
				{
					if(j==n)
					printf("%d\n",a[i][j]);
					else printf("%d ",a[i][j]);
				}
			}
		}
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值