今日头条笔试题

/*
题目描述:
给定两个长度为 n 的整数数列 A 和 B。再给定 q 组查询,每次查询给出两个整数 x 和 y,求满足 Ai >= x 且 Bi >= y 这样的 i 的数量。
输入
第一行给定两个整数 n 和 q。
第二行给定数列 A,包含 n 个整数。
第三行给定数列 B,包含 n 个整数。
接下来 q 行,每行两个整数 x 和 y,意义如上所述。
输出
对于每组查询,输出所求的下标数量。

样例输入
3 2
3 2 4
6 5 8
1 1
4 8
样例输出
3
1
*/



package com.company;
import java.util.Scanner;

/**
 * Created by zhangheng on 2017/8/22.
 */
public class Index {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int length = sc.nextInt();
        int num = sc.nextInt();
        int arr1[] = new int[length];
        int arr2[] = new int[length];
        int res[] = new int[num];

        for(int i=0;i<length;i++){
            arr1[i] = sc.nextInt();
        }
        for(int i=0;i<length;i++){
            arr2[i] = sc.nextInt();
        }
        int count = 0;
        while(count<num){
            int[] arr = new int[num];

            for(int j=0;j<2;j++){
                arr[j] = sc.nextInt();
            }
            res[count++] = findIndex(length,arr1,arr2,arr);
        }
        for(int i=0;i<num;i++){
            System.out.println(res[i]);
        }
    }
    public static int findIndex(int length, int[] arr1, int[] arr2, int[] arr){
        int cnt = 0;

            for(int i=1;i<=length;i++){
                if(arr1[i-1]>=arr[0] && arr2[i-1]>=arr[1]){
                    cnt++;

                }
            }

        return cnt;
    }
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值