SDUT 1500 Message Flood (快排+二分查找)

题目描述

Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.

输入

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

输出

For each case, print one integer in one line which indicates the number of left friends he must send.

示例输入

5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0

示例输出

3


大体题意:输入两个数N和M,前M行是M个字符串str1,后边的N行是N个字符串str2,要求是找出str1中有多少个和str2不同的字符串


思路:应该用哈希,本人用了快排+二分查找,时间较长,也能AC。还有一个问题,就是本题不区分大小写,好坑爹的,输入的字符串应该先全部转化为大写或小写。

对m个字符串排序(快排,还是第一次用快排对字符串排序,好头疼),然后循环n个字符串,一个一个的在M个字符串中查找,最后用N减去相同的个数就可以了。


上代码:


#include <stdio.h>
#include <string.h>
#include <stdlib.h>

char str1[20000][11],str2[20000][11];

void quick(int l , int r)  //快排
{
    char x[11];
    int i=l,j=r;
    strcpy(x,str2[l]);

    if(l>=r) return ;

    while(i<j)
    {
        while(i<j && strcmp(str2[j],x)>=0) j--;
            strcpy(str2[i],str2[j]);
        while(i<j && strcmp(str2[i],x)<=0) i++;
            strcpy(str2[j],str2[i]);
    }

    strcpy(str2[i],x);
   quick(l,i-1);
   quick(i+1,r);

}

int search(int s , int t , char *key) //二分查找(表示全部看课本照葫芦画瓢)
{
    int low=s,high=t,mid;
    if(s<=t)
    {
        mid=low+(high-low)/2;
        if(strcmp(str2[mid],key)==0)
            return 1;
        else if(strcmp(str2[mid],key)>0)
            return search(low,mid-1,key);
        else if(strcmp(str2[mid],key)<0)
            return search(mid+1,high,key);
    }

    return 0;
}

void strup( char *str )  //转换大小写(我全部转换成了大写)
{
    int i, len = strlen(str);

    for ( i = 0; i < len; i++ )
    {
        if( str[i] <= 'z' && str[i] >= 'a' )
            str[i] = str[i] - 'a' + 'A';
    }
}


int main()
{

    int n,m,count;
    int i;

    while(~scanf("%d",&n)&&n)
    {
        scanf("%d",&m);
        count=0;

        for(i=0;i<n;i++)
        {
            scanf("%s",str1[i]);
            strup(str1[i]);
        }

        for(i=0;i<m;i++)
        {
            scanf("%s",str2[i]);
            strup(str2[i]);
        }

        quick(0,m-1);  //对m个字符串快排

        for(i=0;i<n;i++)
        {
            if(search(0,m-1,str1[i]))  //在m个字符串str2中挨个查找str1
                count++;  //查找到的相同的个数
        }

        printf("%d\n",n-count);  
    }
    return 0;
}




Python网络爬虫与推荐算法新闻推荐平台:网络爬虫:通过Python实现新浪新闻的爬取,可爬取新闻页面上的标题、文本、图片、视频链接(保留排版) 推荐算法:权重衰减+标签推荐+区域推荐+热点推荐.zip项目工程资源经过严格测试可直接运行成功且功能正常的情况才上传,可轻松复刻,拿到资料包后可轻松复现出一样的项目,本人系统开发经验充足(全领域),有任何使用问题欢迎随时与我联系,我会及时为您解惑,提供帮助。 【资源内容】:包含完整源码+工程文件+说明(如有)等。答辩评审平均分达到96分,放心下载使用!可轻松复现,设计报告也可借鉴此项目,该资源内项目代码都经过测试运行成功,功能ok的情况下才上传的。 【提供帮助】:有任何使用问题欢迎随时与我联系,我会及时解答解惑,提供帮助 【附带帮助】:若还需要相关开发工具、学习资料等,我会提供帮助,提供资料,鼓励学习进步 【项目价值】:可用在相关项目设计中,皆可应用在项目、毕业设计、课程设计、期末/期中/大作业、工程实训、大创等学科竞赛比赛、初期项目立项、学习/练手等方面,可借鉴此优质项目实现复刻,设计报告也可借鉴此项目,也可基于此项目来扩展开发出更多功能 下载后请首先打开README文件(如有),项目工程可直接复现复刻,如果基础还行,也可在此程序基础上进行修改,以实现其它功能。供开源学习/技术交流/学习参考,勿用于商业用途。质量优质,放心下载使用。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值