求二叉树的深度

题目描述

已知一颗二叉树的中序遍历序列和后序遍历序列,求二叉树的深度。

输入

输入数据有多组,输入T,代表有T组数据。每组数据包括两个长度小于50的字符串,第一个字符串表示二叉树的中序遍历,第二个表示二叉树的后序遍历。

输出

输出二叉树的深度。

示例输入

2
dbgeafc
dgebfca
lnixu
linux

示例输出

4
3


#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct node
{
    char data;
    struct node *l,*r;
};
char str1[1010],str2[1010];
struct node *creat(char *str1,char *str2,int len)
{
    if(len<=0)
    return NULL;

    struct node *root=(struct node*)malloc(sizeof(struct node));
    root->data=str2[len-1];
    int p;
    p=strchr(str1,str2[len-1])-str1;
    root->l=creat(str1,str2,p);
    root->r=creat(str1+p+1,str2+p,len-p-1);
    return root;
}

int deep(struct node *p)
{
    int ld,rd;
    if(!p)
        return 0;
    else
    {
        ld=deep(p->l);
        rd=deep(p->r);
        if(ld>rd)
            return ld+1;
        else
            return rd+1;
    }
}

int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
       int num=0;
       struct node *head;
       scanf("%s %s",str1,str2);
       int l=strlen(str2);
       head=creat(str1,str2,l);
       num=deep(head);
       printf("%d\n",num);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值