PAT (Advanced Level)1018 Public Bike Management (30分)

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S​3​​, we have 2 different shortest paths:

  1. PBMC -> S​1​​ -> S​3​​. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S​1​​ and then take 5 bikes to S​3​​, so that both stations will be in perfect conditions.

  2. PBMC -> S​2​​ -> S​3​​. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: C​max​​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S​p​​, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C​i​​ (i=1,⋯,N) where each C​i​​ is the current number of bikes at S​i​​ respectively. Then M lines follow, each contains 3 numbers: S​i​​, S​j​​, and T​ij​​ which describe the time T​ij​​ taken to move betwen stations S​i​​ and S​j​​. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S​1​​−>⋯−>S​p​​. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S​p​​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge's data guarantee that such a path is unique.

Sample Input:

10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1

Sample Output:

3 0->2->3 0

思路

最短路径dijkstra算法+dfs

代码 

#include<stdio.h>
#include<algorithm>
#include<vector>
using namespace std;
const int inf=99999999;
int cmax,n,sp,m;
int minNeed=inf,minBack=inf;
int e[510][510],dis[510],weight[510];
bool visit[510]={false};
vector<int> pre[510];
vector<int> path,temppath;
void dfs(int v){
	temppath.push_back(v);
	if(v==0){
		int need=0,back=0;
		for(int i=temppath.size()-1;i>=0;i--){
			int id=temppath[i];
			if(weight[id]>0)
				back+=weight[id];
			else{
				if(back>(0-weight[id]))
					back+=weight[id];
				else{
					need+=((0-weight[id])-back);
					back=0;
				}
			}
		}
		if(need<minNeed){
			minNeed=need;
			minBack=back;
			path=temppath;
		}else if(need==minNeed&&back<minBack){
			minBack=back;
			path=temppath;
		}
		temppath.pop_back();
		return;
	}
	for(int i=0;i<pre[v].size();i++)
		dfs(pre[v][i]);
	temppath.pop_back();
}
int main(){
	fill(e[0],e[0]+510*510,inf);	//初始化边权为inf 
	fill(dis,dis+510,inf);			//初始化0到每个结点的距离为inf 
	scanf("%d%d%d%d",&cmax,&n,&sp,&m);
	for(int i=1;i<=n;i++){	//输入每个点的自行车数量(离最完美数量的差值) 
		scanf("%d",&weight[i]);
		weight[i]=weight[i]-cmax/2;
	}
	for(int i=0;i<m;i++){	//输入每条边的边权 
		int a,b;
		scanf("%d%d",&a,&b);
		scanf("%d",&e[a][b]);
		e[b][a]=e[a][b];
	}
	//最短路径迪杰斯特拉算法 
	dis[0]=0;
	for(int i=0;i<=n;i++){	//遍历n次 
		int u=-1,minn=inf;
		for(int j=0;j<=n;j++){	//找到路径最短的结点
		//如果j没有被访问,而且0到j的距离比现在的最短距离minn小 
			if(visit[j]==false&&dis[j]<minn){
				u=j;
				minn=dis[j];
			}
		}
		//找不到未被访问的结点 
		if(u==-1) break;
		visit[u]=true;
		for(int v=0;v<=n;v++){
			//如果该结点未访问,可达,到v的距离更小了 
			if(visit[v]==false&&e[u][v]!=inf&&dis[v]>dis[u]+e[u][v]){
				dis[v]=dis[u]+e[u][v];	//更新距离 
				pre[v].clear();
				pre[v].push_back(u);
			}else if(dis[v]==dis[u]+e[u][v])
				pre[v].push_back(u);
		}
	} 
	dfs(sp);
	printf("%d 0",minNeed);
	for(int i=path.size()-2;i>=0;i--)
		printf("->%d",path[i]);
	printf(" %d",minBack);
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值