hdu1105

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 153645    Accepted Submission(s): 37479


Problem Description
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).
 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

Output
For each test case, print the value of f(n) on a single line.
 

Sample Input
  
  
1 1 3 1 2 10 0 0 0
 

Sample Output
  
  
2 5
 

Author
CHEN, Shunbao
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1008 1004 1021 1019 1002

解题思路:由于题目给出的数据1 <= n <= 100,000,000,数据太大,若按照题目意思进行递归,定会超时,所以只能寻找规律。
解题心得:在比赛的时候,就想着这题目一点规律也没有,也不好证明,就一直在纠结,这种题目就不应该出现在acm中,简直折磨人。到后面自己心平气和的坐下来,慢慢的思考这个问题时,发现自己还是太急躁了,我可以用递归的那种方法写出程序,再打印出结果,也不用自己算,慢慢的找规律。还是要少一点抱怨,多用一点脑子。
用于寻找规律的代码
#include <iostream>
#include<cstdio>
using namespace std;
int a,b,n,c[100000005];
int main()
{
    while(scanf("%d%d%d",&a,&b,&n)&&a!=0&&b!=0&&n!=0)
    {
        c[1]=1;
        c[2]=1;
        printf("1 1 ");
        for(int i=3;i<=n;i++)
        {
            c[i]=(a*c[i-1])%7+(b*c[i-2])%7;
            printf("%d ",c[i]);
        }
        printf("\n");
    }
    return 0;
}
各种测试数据的结果:

ac代码:
#include <iostream>
#include<cstdio>
using namespace std;
int a,b,n,i,c[10000];
int main()
{
    c[1]=1;
    c[2]=1;
    while(scanf("%d%d%d",&a,&b,&n)&&a&&b&&n)
    {
        for(i=3;i<10000;i++)
        {
            c[i]=(a*c[i-1]+b*c[i-2])%7;
            if(c[i]==1&&c[i-1]==1)
                break;
        }
        n=n%(i-2);
        c[0]=c[i-2];
        printf("%d\n",c[n]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值