Topological Order (判断是不是拓扑排序

所谓拓扑排序就是删除入度为0的点的顺序
This is a problem given in the Graduate Entrance Exam in 2018: Which of the following is NOT a topological order obtained from the given directed graph? Now you are supposed to write a program to test each of the options.

在这里插入图片描述

Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers N (≤ 1,000), the number of vertices in the graph, and M (≤ 10,000), the number of directed edges. Then M lines follow, each gives the start and the end vertices of an edge. The vertices are numbered from 1 to N. After the graph, there is another positive integer K (≤ 100). Then K lines of query follow, each gives a permutation of all the vertices. All the numbers in a line are separated by a space.

Output Specification:
Print in a line all the indices of queries which correspond to “NOT a topological order”. The indices start from zero. All the numbers are separated by a space, and there must no extra space at the beginning or the end of the line. It is graranteed that there is at least one answer.

Sample Input:
6 8
1 2
1 3
5 2
5 4
2 3
2 6
3 4
6 4
5
1 5 2 3 6 4
5 1 2 6 3 4
5 1 2 3 6 4
5 2 1 6 3 4
1 2 3 4 5 6
Sample Output:
3 4

#include<bits/stdc++.h>
#include <iostream>
#include <map>
#include <string>
#include<vector>
#include<stack>
using namespace std;
map<int ,vector<int> > mp;
int ru[100005];
int chu[100005];
int ru2[100005];
int chu2[100005];
int main() {
	int n,m;
	cin>>n>>m;
	for(int i=0;i<m;i++)
	{
		int a,b;
		cin>>a>>b;
		chu[a]++;
		ru[b]++;
		mp[a].push_back(b);
	}
	int k;
	cin>>k;
	vector<int>ans;
	for(int i=0;i<k;i++)
	{
		for(int u=1;u<=n;u++)
		{
			ru2[u]=ru[u];
			chu2[u]=chu[u];
		//	cout<<ru2[u]<<endl;
		}
	
		
		int flag=1;
		for(int j=0;j<n;j++)
		{
			int tmp;
			cin>>tmp;
			if(ru2[tmp]==0)
			{
				
				for(int t=0;t<mp[tmp].size();t++)
				{
					ru2[mp[tmp][t]]--;
				}
				
			}
			else
			{
			//	cout<<j<<endl;
				flag=0;
			}
			
		}
		if(flag==0) ans.push_back(i);
	}
	
	for(int i=0;i<ans.size()-1;i++)cout<<ans[i]<<" ";
	cout<<ans[ans.size()-1];
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值