基本上就是由中序遍历和后序遍历求前序遍历
将前序遍历按层数存,输出的时候根据层数的奇偶按顺序/逆序输出就可以了
Suppose that all the keys in a binary tree are distinct positive integers. A unique binary tree can be determined by a given pair of postorder and inorder traversal sequences. And it is a simple standard routine to print the numbers in level-order. However, if you think the problem is too simple, then you are too naive. This time you are supposed to print the numbers in “zigzagging order” – that is, starting from the root, print the numbers level-by-level, alternating between left to right and right to left. For example, for the following tree you must output: 1 11 5 8 17 12 20 15.
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the inorder sequence and the third line gives the postorder sequence. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the zigzagging sequence of the tree in a line. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
8
12 11 20 17 1 15 8 5
12 20 17 11 15 8 5 1
Sample Output:
1 11 5 8 17 12 20 15
#include<bits/stdc++.h>
#include <iostream>
#include<stack>
#include<string>
#include<vector>
using namespace std;
vector<int>ans[10005];
int in[10005],po[10005];
int maxcen=-1;
void tra(int now,int l,int r,int cen) {
if(l>r)return ;
int i=1;
while(in[i]!=po[now])i++;
ans[cen].push_back(po[now]);
// cout<<po[now]<<" ";
tra(now-(r-i)-1,l,i-1,cen+1);
tra(now-1,i+1,r,cen+1);
if(cen>maxcen)
maxcen=cen;
}
int main() {
int n;
cin>>n;
for(int i=1; i<=n; i++) {
cin>>in[i];
}
for(int i=1; i<=n; i++) {
cin>>po[i];
}
int root=po[n];
tra(n,1,n,1);
cout<<ans[1][0];
for(int i=2; i<=maxcen; i++) {
if(i%2==0) {
for(int j=0; j<ans[i].size(); j++) {
cout<<" "<<ans[i][j];
}
} else {
for(int j=ans[i].size()-1; j>=0; j--) {
cout<<" "<<ans[i][j];
}
}
}
return 0;
}