poj2411 Corn Fields(状态压缩)

Corn Fields
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 13566 Accepted: 7122

Description

Farmer John has purchased a lush new rectangular pasture composed of M by N (1 ≤ M ≤ 12; 1 ≤ N ≤ 12) square parcels. He wants to grow some yummy corn for the cows on a number of squares. Regrettably, some of the squares are infertile and can't be planted. Canny FJ knows that the cows dislike eating close to each other, so when choosing which squares to plant, he avoids choosing squares that are adjacent; no two chosen squares share an edge. He has not yet made the final choice as to which squares to plant.

Being a very open-minded man, Farmer John wants to consider all possible options for how to choose the squares for planting. He is so open-minded that he considers choosing no squares as a valid option! Please help Farmer John determine the number of ways he can choose the squares to plant.

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes row  i of the pasture with  N space-separated integers indicating whether a square is fertile (1 for fertile, 0 for infertile)

Output

Line 1: One integer: the number of ways that FJ can choose the squares modulo 100,000,000.

Sample Input

2 3
1 1 1
0 1 0

Sample Output

9

Hint

Number the squares as follows:
1 2 3
  4  

There are four ways to plant only on one squares (1, 2, 3, or 4), three ways to plant on two squares (13, 14, or 34), 1 way to plant on three squares (134), and one way to plant on no squares. 4+3+1+1=9.


题意:一个n*m的矩形草场,1表示可以种植,0表示不可以,选择种植的小方块不能相邻,问有多少种方案(包括空集)

用状态压缩枚举所有的可能,进行递推。

/*************************************************************************
	> File Name: code/now.cpp
	> Author: Zz
	> Created Time: 2016年09月17日 星期六 15时47分37秒
 ************************************************************************/

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<string>
#include<stack>
#include<queue>
#include<map>
#include<set>
#include<vector>
#include<list>
using namespace std;
#define N 15
#define MOD 100000000 
int dp[N][1<<N];
int zu[N];
bool checkA(int x)
{
	return !(x&(x>>1)||x&(x<<1));
}
bool checkB(int a,int b)
{
	return !(a&b);
}
int main()
{
	int n,m;
	scanf("%d %d",&n,&m);
	for(int i=0;i<n;i++)
		for(int j=0;j<m;j++)
		{
			int x;
			scanf("%d",&x);
			if(x)
				zu[i]=(zu[i]|(1<<j));
		}

	for(int i=0;i<(1<<m);i++)
		if((zu[0]|i)==zu[0]&&checkA(i))
			dp[0][i]=1;

	for(int i=1;i<n;i++)
		for(int j=0;j<(1<<m);j++)
			if((zu[i]|j)==zu[i]&&checkA(j))
			for(int l=0;l<(1<<m);l++)
				if(checkB(j,l))
					dp[i][j]=(dp[i][j]+dp[i-1][l])%MOD;

	long long ans=0;
	for(int i=0;i<(1<<m);i++)
		ans=(ans+dp[n-1][i])%MOD;
	printf("%lld\n",ans);

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值