hdu 1400 (插头)

Mondriaan's Dream

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 1215    Accepted Submission(s): 781

Problem Description
Squares and rectangles fascinated the famous Dutch painter Piet Mondriaan. One night, after producing the drawings in his 'toilet series' (where he had to use his toilet paper to draw on, for all of his paper was filled with squares and rectangles), he dreamt of filling a large rectangle with small rectangles of width 2 and height 1 in varying ways. 
Expert as he was in this material, he saw at a glance that he'll need a computer to calculate the number of ways to fill the large rectangle whose dimensions were integer values, as well. Help him, so that his dream won't turn into a nightmare! 
 

Input
The input file contains several test cases. Each test case is made up of two integer numbers: the height h and the width w of the large rectangle. Input is terminated by h=w=0. Otherwise, 1<=h,w<=11. 
 

Output
For each test case, output the number of different ways the given rectangle can be filled with small rectangles of size 2 times 1. Assume the given large rectangle is oriented, i.e. count symmetrical tilings multiple times.
 

Sample Input
   
   
1 2 1 3 1 4 2 2 2 3 2 4 2 11 4 11 0 0
 

Sample Output
   
   
1 0 1 2 3 5 144 51205
题意:计算用1*2的矩形铺满n*m矩形的方案数
思路:用轮廓线插头dp的思想,有插头用1标记,无插头用0标记,这题中一个格子中要么无插头,要么只有一个插头,不可能有两个插头。
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int n,m;
typedef long long LL;
LL dp[13][13][1<<13];
void dp_ct()
{
	memset(dp,0,sizeof(dp));
	dp[0][m][0]=1;
	//初始化
	for(int i=1;i<=n;++i)
	{
		for(int k=0;k<(1<<m);++k)
			dp[i][0][(k<<1)]=dp[i-1][m][k];
		//行首初始化
		for(int j=1;j<=m;++j)
		{
			int x=1<<j;
			int y=1<<(j-1);
			//
			for(int k=0;k<(1<<(m+1));++k)
			{
				if(!(k&x)&&(k&y))//一个插头
					dp[i][j][k]=dp[i][j-1][k^y];
				else if((k&x)&&!(k&y))//一个插头
					dp[i][j][k]=dp[i][j-1][k^x];
				else if(!(k&x)&&!(k&y))//无插头
					dp[i][j][k]=(dp[i][j-1][k^x]+dp[i][j-1][k^y]);
			}
		}
	}
}
int main()
{
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		if(n==0&&m==0)
			return 0;
		dp_ct();
		printf("%lld\n",dp[n][m][0]);
	}
}


   
   
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值