1095 Cars on Campus (30 分) 排序+cmp 好题

1095 Cars on Campus (30 分)

Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (≤10​4​​), the number of records, and K (≤8×10​4​​) the number of queries. Then N lines follow, each gives a record in the format:

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an outrecord. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and out at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in ascending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

具体代码

#include <cstdio>
#include <cstring>
#include <map>
#include <string>
#include <algorithm>
using namespace std;
int num=0;
struct Car{
    char id[8];
    int time;//记录车的进出时间
    char status[4];

}all[10010],valid[10010];//记录所有的进出记录以及有效e的进出记录

bool cmpbyidandtime(Car a,Car b){
    if(strcmp(a.id,b.id))return strcmp(a.id,b.id)<0;
    else return a.time<b.time;
}

bool cmpbytime(Car a,Car b){
    return a.time<b.time;
}

int intos(int hh,int mm,int ss){
    return hh*3600+mm*60+ss;
}//将停车时间以s为单位

map<string,int>parktime;//车牌号->总停留时间

int main(){
    int n,k,hh,mm,ss;
    scanf("%d%d",&n,&k);
    for(int i=0;i<n;i++){
        scanf("%s %d:%d:%d %s",all[i].id,&hh,&mm,&ss,all[i].status);
        all[i].time=intos(hh,mm,ss);//将all中的所有进出时间时间转换为秒

    }

    sort(all,all+n,cmpbyidandtime);//按车牌和时间来j排序

int maxtime=-1;//maxtime不能放在for循环中初始化

    for(int i=0;i<n-1;i++){

       
        if(!strcmp(all[i].id,all[i+1].id)&&!strcmp(all[i].status,"in")&&!strcmp(all[i+1].status,"out")){//字符串的比较用strcmp
            valid[num++]=all[i];
            valid[num++]=all[i+1];
            int intime=all[i+1].time-all[i].time;//记录该次的停留时间
            if(parktime.count(all[i].id)==0){parktime[all[i].id]=0;}//如果map中没有该车牌号,将该车牌号的总停留时间置零。
            parktime[all[i].id]+=intime;//计算该车的停留总时间
            maxtime=max(maxtime,parktime[all[i].id]);//更新最大停留时间
            
        }
        
    }

    sort(valid,valid+num,cmpbytime);//i将valid按照时间从小到大排序,方便下面的查询
    int now=0,numcar=0;//numcar为此时校园内的车辆数
    for(int i=0;i<k;i++){
        scanf("%d:%d:%d",&hh,&mm,&ss);
        int time=intos(hh,mm,ss);//令time为j查询截止时间
        while(now<num&&valid[now].time<=time){
            if(!strcmp(valid[now].status,"in"))numcar++;
            else numcar--;
            now++;
        }
        printf("%d\n",numcar);

    }
map<string,int>::iterator it;
for(it=parktime.begin();it!=parktime.end();it++){
    if(it->second==maxtime)printf("%s ",it->first.c_str());

}
printf("%02d:%02d:%02d\n",maxtime/3600,maxtime%3600/60,maxtime%60);

return 0;




}




 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值