1010 Radix (25 分) 超级坑恶魔坑

1010 Radix (25 分)

Given a pair of positive integers, for example, 6 and 110, can this equation 6 = 110 be true? The answer is yes, if 6 is a decimal number and 110 is a binary number.

Now for any pair of positive integers N​1​​ and N​2​​, your task is to find the radix of one number while that of the other is given.

Input Specification:

Each input file contains one test case. Each case occupies a line which contains 4 positive integers:


N1 N2 tag radix

Here N1 and N2 each has no more than 10 digits. A digit is less than its radix and is chosen from the set { 0-9, a-z } where 0-9 represent the decimal numbers 0-9, and a-z represent the decimal numbers 10-35. The last number radix is the radix of N1 if tag is 1, or of N2 if tag is 2.

Output Specification:

For each test case, print in one line the radix of the other number so that the equation N1 = N2 is true. If the equation is impossible, print Impossible. If the solution is not unique, output the smallest possible radix.

Sample Input 1:

6 110 1 10

Sample Output 1:

2

Sample Input 2:

1 ab 1 2

Sample Output 2:

Impossible

具体代码

#include <cstdio>
#include <algorithm>
#include <cstring>
#include <math.h>
using namespace std;
typedef long long LL;
LL Map[256];
LL inf=pow(2,63)-1;

void init(){
    for(char c='0';c<='9';c++){
        Map[c]=c-'0';
    }
    for(char c='a';c<='z';c++){
        Map[c]=c-'a'+10;
    }
}

LL num10(char a[],LL radix,LL t){//将a转换为10进制,t为上界
   LL ans=0;
   int len=strlen(a);
   for(int i=0;i<len;i++){
       ans=ans*radix+Map[a[i]];
       if(ans<0||ans>t)return -1;
   }


return ans;


}

int cmp(char N2[],LL radix,LL t){
    int len=strlen(N2);
    LL num=num10(N2,radix,t);
    if(num<0)return 1;//溢出,N2>t;
    if(t>num)return -1;//t较大,返回-1
    else if(t==num)return 0;//相等
    else return 1;//num较大
}


LL binary(char N2[],LL left,LL right,LL t){
    LL mid;
    while(left<=right){
        mid=(left+right)/2;
        int flag=cmp(N2,mid,t);//N2转为10进制后与tj比较
        if(flag==0)return mid;
        else if(flag==-1)left=mid+1;
        else right=mid-1;
    }
    return -1;
}

int find(char N2[]){
    int ans=-1,len=strlen(N2);
    for(int i=0;i<len;i++){
        if(Map[N2[i]]>ans){
            ans=Map[N2[i]];
        }
    }
    return ans+1;
}

char N1[15],N2[15],temp[15];
int tag,radix;
int main(){
    init();
    scanf("%s %s %d %d",N1,N2,&tag,&radix);
    if(tag==2){
      swap(N1,N2);
    }
LL t=num10(N1,radix,inf);//将N1z转换为10进制
LL low=find(N2);//找到N2中最大的数位
LL high=max(low,t)+1;//上界
LL ans=binary(N2,low,high,t);
if(ans==-1)printf("Impossible\n");
else printf("%lld\n",ans);
return 0;

    }

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值