1015 Reversible Primes (20 分)可逆质数

1015 Reversible Primes (20 分)

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (<10​5​​) and D (1<D≤10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line Yes if N is a reversible prime with radix D, or No if not.

Sample Input:

73 10
23 2
23 10
-2

Sample Output:

Yes
Yes
No

思路:

1.题目中有多个输入但没有明确输入的个数,并且有负数来表示输入的结束,可以用while(scanf("%d",&n)!=EOF)来控制输入的结束。

2.输入的n为负数,直接跳出while循环,因为输入已到达尾部。

判断输入的n是否为质数,不是输出No,是则进行下一步。

3.将n转换为radix进制存入d[]数组,再将d[]数组从0到len-1   进行 n=n*radix+d[i]转换为逆的radix进制n。

4.判断n是否为质数。

#include <cstdio>
#include <cmath>
bool isprime(int c){
    if(c<=1)return false;
    int sqr=(int)sqrt(c);
    for(int i=2;i<=sqr;i++){
        if(c%i==0)return false;
        
    }
    return true;
}

int main(){
    int n,radix;
    int d[100];
    while(scanf("%d",&n)!=EOF){
        if(n<0)break;
        scanf("%d",&radix);
        if(isprime(n)==false){printf("No\n");}
        else {
            int len=0;
            while(n!=0){
                d[len++]=n%radix;
                n/=radix;
            }
            for(int i=0;i<len;i++){
                n=n*radix+d[i];
            }
            if(isprime(n)==false)printf("No\n");
            else printf("Yes\n");


        }
        
        
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值